BrainVoyager Support

documentation overview

  • Increase font size
  • Default font size
  • Decrease font size

BrainVoyager 20.4 / QX 3.4 Release Notes

BrainVoyager 20.4 / BVQX 3.4 Release Notes



New Features

Two-Factor ANOVA A new ANOVA model with two between-subjects factors has been added to the "ANCOVA" dialog allowing to model more complex designs with each subject grouped in two ways allowing to investigate main effects and interaction effects. The implementation supports unbalanced designs using type III sums of squares, i.e. with unequal number of observations (subjects) for level combinations of the two factors. For further details consult the "Two-Factor ANOVA" topic in the "Statistical Data Analysis - Random Effects Group Analysis" chapter of the updated User's Guide.
Equi-Volume Depth Sampling For the analysis of local sub-millimeter data, BrainVoyager allows to model regular 2D grids at different cortical depth levels. In past versions these grids were placed using an equidistant approach keeping a specified relative cortical depth level with respect to the cortex boundaries. BrainVoyager 20.4 adds an equi-volume approach adjusting the thickness of layers in cortical segments to preserve their volume compensating for cortical folding, which better corresponds to layers in brain tissue than the equi-distant modeling approach. The equi-volume approach is also available for full cortex depth meshes. For further details consult the "Equi-Volume Depth Modelling" topic in the "Analysis of Sub-Millimeter 7T+ Data" chapter of the updated User's Guide.
Decoding pRF Models Population receptive field (pRF) modeling is a useful approach to map the location and area of the visual field represented by voxels (or vertices) in the visual cortex serving as the basis to calculate eccentricity and polar angle maps. The obtained cortical visual field maps can also be used "backwards" to plot the activation of voxels in visual areas in a visual field representation. This is supported by new tools in BrainVoyager 20.4. First, clicking on a voxel or vertex in the cortex while a pRF map is loaded will show the corresponding location and size of the corresponding pRF model in a visual field plot in the "Image Reporter". Furthermore, the "Decode" button can be used to project the current cortical activation pattern (evoked e.g. by a visual stimulus or visual imagery) in a visual field image. For details see topic "Decoding pRF Models" in the "Population Receptive Field Analysis" chapter of the updated User's Guide.

 

Enhancements

High-Resolution Data Volume Rendering In order to visualize high-resolution data, especially "flattened" cortical depth grids, the "High-Resolution Data Volume Rendering" tool has been introduced in BrainVoyager 20.2. This version adds new possibiliities to this tool allowing e.g. to (temporarily) cut out sub-volumes for visualization purposes and to show/hide the 3D reference grid. For details see topic "Advanced Volume Rendering of High-Resolution Data" in the "Analysis of Sub-Millimeter 7T+ Data" chapter of the updated User's Guide.
Anonymization of DICOM Files In an extension of the Rename DICOM files tool, it is now possible to specify an anonymized code string for a participant (e.g. "P17") that will replace the patient name element in DICOM files and also used for renaming the files. Like the Rename DICOM function, files are renamed to a standard format "PatientsName-SeriesNumber-VolumeNumber-ImageNumber.dcm" that is optimized for subsequent document creation functions. Note that in this version of BrainVoyager the anonymization routine does not change other fields in DICOM files besides the patient name element (other elements will be made available for anonymization in a later release). Note also that all DICOM files found in the specified folder receive the same new (coded) patient name, i.e. all files in the directory should be from the same participant. The tool can be invoked using the "Anonymize and Rename DICOM Files" in the "File" menu.
Scripting API New scripting commands for FMR-VMR coregistration (with and without BBR), MNI normalization and VTC creation in MNI space have been added to the (VMR) document object. Furthermore, the anonymization functionality described above has been also made available via scripting ("AnonymizeDicomFilesInDirectory" command). A new "Python Developer Guide" has been made available that can be launched from the "Help" menu and in the "Python Development Window". Also more Python scripts and plugins are made available in the "PythonScripts" and "PythonPlugins" folders. Note that the Python and JavaScript scripting API now expects "BrainVoyager" instead of "BrainVoyagerQX" as the main application object. The same holds true also for the external COM-based access on Windows (e.g. from Matlab). While both names can still be used during the 20.x releases, version 21 of BrainVoyager will only support the "BrainVoyager" application object. Note also that the "CreateProjectFMR/DMR/VMR/AMR" commands have been renamed to "CreateDocumentFMR/DMR/VMR/AMR" to be consistent with the terminology used in the data analysis manager and now generally in BrainVoyager. For the 20.x releases, the "CreateProject.." names can still be used, but they will be removed in version 21.
POI to SMP The "Create SMP" button in the new "Create SMP from POI" field in the "Advanced" tab of teh "Surface Maps" dialog allows to convert a specified POI into a surface map where the vertices of the POI are set to an "active" value (default: 1.0) while all other vertices are set to value 0.0. This function may be useful in some cases, e.g. when a map is needed from interactively specified vertices (see, for example, description in interactive pRF decoding section in the "Decoding pRF Models" topic in the User's Guide). A similar conversion is available with the standard VOM to VMP conversion in volume space by using the "Create VMP" button in the "Visualize VOMs" dialog; this conversion is now also possible when the VOM contains no map data (only voxel coordinates); in this case the voxels of the VOM will be set to activity value 1.0 while all other voxels of the map will be set to value 0.0 in the resulting volume map (with bounding box dimensions from a previously created/loaded VMP).
Document Context Menus A useful and quick way to launch often used operations is available via local menus for FMR, DMR, VMR, and SRF documents that can be shown by context-clicking (e.g. right clicking) the title bar of a document tab (or window) or by using the document thumbnail in the "Open Documents" pane. The local menus have been extended with entries for invoking document property dialogs (e.g. "VMR Properties" dialog) as well as entries to show property dialogs of linked data if attached to a document ("VTC Properties", "VDW Properties", "MTC Properties"). The local menu of VMR documents now also contains an entry to call the "Volume-Of-Interest Analysis" dialog and SRF documents contain an entry to call the "Patches-Of-Interest Analysis" dialog.

 

Bug Fixes

Bridge Removal When running the bridge removal tool more than once, BrainVoyager 20.2 would crash; this included running the automatic segmentation pipeline from the "Automatic Cortex Segmentation and Reconstruction" dialog with the "Remove bridges LH" and "Remove bridges RH" options enabled. This issue has been fixed.
NIfTI Plugin On Windows the NIfTI plugin did not work in BrainVoyager 20.2. This issue has been fixed.
Changing Inter-Slice Time Value When changing the "Inter slice time" value in the "FMR Properties" dialog, the value was set to the default value (TR value divided by the number of slices) when relaoding the saved FMR file from disk, i.e. the displayed "Inter slice time" value did not match the value in the FMR file. This issue has been fixed.
ACPC Space Flag When running the automatic ACPC-TAL normalization routine by clicking the "Auto-ACPC-TAL" button in the "Talairach" tab of the "3D Volume Tools" dialog, the space of the created ACPC VMR file was incorrectly set to "unknown" instead of "ACPC" space. This has been corrected.
VOIs in MNI Space If VOIs were defined in MNI space, they were stored to disk as internal BV coordinates, which could lead to subsequent errors, e.g. when adding them to other VOI files. Like TAL space VOIs, the coordinates of VOIs in MNI space are now saved and loaded properly marked as being in MNI space. In order to more easily recognize the space of the currently loaded/created VOIs, a new reference space label has been added to the "Volume-Of-Interest Analysis" dialog.
VDWs in MNI Space Transforming DMR data into MNI space VDW files did not work properly in previous 20.x versions, i.e. the resulting bounding box could be different for each data set. This has been fixed and VDW files created from DMR data from different runs/subjects are now placed in the standard MNI bounding box.
GLM as Input for ANOVA When using a GLM as input for the ANOVA (1 between factor) model in the "ANCOVA" dialog, the program would crash; the tool worked, however, well when using properly created VMP/SMP files as input (recommended). The issue with GLM input has been fixed.
LUTs for Volume and Surface Maps When visualizing volume or surface maps using look-up table (.olt) files, the correct map colors were not always selected for displaying the color bar as well as the map itself; furthermore the map icons in the "Volume Maps" or "Surface Maps" dialogs were often not correctly displayed. This issue has been fixed.
AutoTransform-ToIsoVoxelation The "AutoTransformToIsoVoxel" scripting command did not work correctly. This issue has been fixed. Furthermore a related new scripting command "TransformToIsoVoxel" has been added allowing to specify explicitly the target resolution and the bounding cube dimension value with additional parameters, which is useful especially for high-resolution VMR data.
Launching GUI Scripts When launching GUI scripts from the JavaScript Script Editor, the user interface (.ui) file referred in the JavaScript (.js) file could sometimes not be loaded since the path to the .ui file was not determined correctly. This issue has been fixed.
Export DICOM When using the "Export .DCM" function in the "Spatial Transf" tab of the "3D Volume Tools" dialog, the export could fail in case that the original DICOMS were stored in big endian byte order. This issue has been fixed.
Float DICOM STCs When creating FMR or DMR projects using non-mosaic DICOM data, the resulting STC/DWI data was always stored in 2-byte integer (short) format even in case that float values were requested (e.g. in the Create Document dialog or via the "Float (4 bytes)" option in the "Data" tab of the "Preferences" dialog). This issue has been fixed.
Motion Correction Clip When turning on the "Movie" option in the "3D motion correction" field in the "FMR Data Preprocessing" dialog, the respective video clip demonstrating the effect of motion correction was not created correctly and the program could crash. This issue has been fixed.