BrainVoyager Support

documentation overview

  • Increase font size
  • Default font size
  • Decrease font size

BrainVoyager 20.2 / QX 3.2 Release Notes

BrainVoyager 20.2 / BVQX 3.2 Release Notes



New Features

Boundary-Based Registration (BBR) Boundary-based registration (BBR) has been added at various processing stages since it provides high-quality coregistration of anatomical and functional data sets (as well as other modalities) of the same subject. BBR uses a reconstructed white matter / grey matter cortex mesh representing the anatomical data that can be automatically created. The mesh is "projected" into a functional (or other) data set and spatially transformed in such a way that the vertices are located at positions where the white / grey matter intensity gradient along the normal direction is maximized. This is the case when the vertices align along the white grey matter boundary. BBR is provided as the default fine-tuning alignment approach when using the FMR - VMR coregistration workflow in the data analysis manager. It is also available for standard FMR - VMR (DMR - VMR) fine-tuning for standard and (sub-millimeter) functional data in FMR-VTC space. Furthermore, BBR can be used to optimize the sampling of functinal data on a cortex mesh. For further details consult the "Boundary-Based Registration" topic of the updated User's Guide.
High-Resolution Data Volume Rendering While BrainVoyager has a real-time volume renderer, there are some advanced features that are useful for high-resolution (sub-millimeter) data such as showing functional data within transparent grey matter tissue in small cortical regions as analyzed with the cortical depth grid sampling method. To allow advanced visualization optimized for such data, a new high-resolution data volume rendering tool is now available that can be called using the s"High-Res Data Volume Renderings" item in the s"Volumess" menu. The tool can also be used to visualize volumetric grid data (see below). For more details, see topic s"Advanced Volume Rendering of High-Resolution Datas" in the "Volume Rendering" chapter of the updated User's Guide.

 

Enhancements

Data Analysis Manager The data analysis manager now supports saving custom choices of preprocessing options in json files allowing consistent data preprocessing across projects. Furthermore, the default parameter setting files can be shared with other BrainVoyager users to ensure consistent preprocessing choices in a team or between colleagues in different labs. For details see topic "Default Preprocessing Choices" in the "Data Analysis Management" chapter of the updated User's Guide.
MNI Segmentation Templates In the previous version, Talairach segmentation templates were used to remove subcortical structures and the cerebellum when running the standard and advanced segmentation pipelines from T1 weighted VMRs transformed in MNI space. For improved subcortical segmentation results, this version provides new segmentation templates that have been created in MNI-152 space. The segmentation templates are installed in the BrainVoyager folder ("BrainMNIMask.vmr" and "BrainMNIMask_0.5mm.vmr" files) and used when segmenting 3D anatomies in normalized MNI space. This change is reflected in the respective "Automatic Cortex Segmentation and Reconstruction" and "Advanced Segmentation Tools" dialogs showing an MNI space option (next to ACPC and TAL) that is automatically turned on when starting the tools from a MNI space VMR.
Cortical Depth Grids As Volumes Reconstructed cortical depth grids can now be converted into VMR volumes together with any sampled map data by stacking the sampled grids on top of each other. The created VMR and VMP data provides a useful "flattened" volumetric visualization of sub-millimeter MRI depth data from a folded cortical region. The volumetric representation allows, for example, the analysis and visualization of activity along the cortex in two dimensions and across cortical depth in the third dimension. The tool can be launched using the "Export Grid Volume" button in the "Visualization" tab of the "High-Resolution Cortex Grid Sampling" dialog. The resulting volumes can be visualized with the advanced volume rendering tool described above. For details see topic "Depth Grids As Flattened Volumes" in the "Analysis of Sub-Millimeter 7T+ Data" chapter of the updated User's Guide.
Mesh VMR Projection Projecting a mesh into a VMR has been improved including automatic creation of a VOI overlay instead of directly drawing into the VMR as in previous versions. The VOI color can also be selected from a set of color buttoons before clicking the "Mesh → VMR" button in the "Mesh Transformations" dialog. The "Adjust Origin To VMR" button aligns the center of the mesh to the VMR, which may be necessary in case that the mesh has been transformed from one space to another space (e.g. when using Un-TAL/inverse ACPC transformation into native space with a different number of dimensions). The projection into the hosting VMR can also be controlled using the "Adjust Vertex Coords" option to displace the drawing along the vertex normal. For details of these new options, see topic "Projecting a Mesh in a VMR" in the "Miscellaneous Tools" chapter of the updated User's Guide.
Secondary/Tertiary VMR In previous versions it was possible to generate, load and save (only for secondary VMR) VMR data sets that are attached to the primary VMR. In this version both secondary and tertiary VMRs can be loaded, saved and removed using the respective entries in the "File" menu.
Spatial Transformation When applying a spatial transformation, it is assumed that the target space has the same framing cube dimension as the source space. For some transformations such as when transforming a VMR or mesh (e.g. for BBR) from native space to FMR-VTC space, this assumption may be wrong resulting in VMRs and meshes that are displaced with respect to the FMR-VTC space. In order to ensure correct transformations also in such cases, the "Mesh Transformations" and "Transform Native VMR To FMR-VTC Space" dialogs now allow to specify the framing cube dimension of the target space leading to expected transformation results.
VOI Visualization When selecting and showing different VOIs in the "Volume-Of-Interest Analysis" dialog, the cross in the current VMR data is adjusted to the center of gravity of the selected VOI. While this is usually helpful, it is sometimes desired to keep the slicing constant when switching VOIs. This scenario is now supported by turning off the new "Adjust VMR cross" option before clicking "Show VOIs".
Reveal document in Explorer/Finder The context menu that is available by right clicking on a documents tab, title bar or document icon in the Open Documents pane helps to quickly launch document specific functionality. The new "Reveal In Finder" (Mac OS X) or "Reveal in Explorer" (Windows) item in the context menu allows to reveal the file location of the respective document in the systems directory tree, i.e. the file location will be marked within an existing or newly opened window in the standard Finder/Explorer of the operating system. This functionality is also available in the "Data" tab of the data analysis manager since BV 20.0.
Open Template MNI/TAL VMR As a convenience, the two entries "Open MNI VMR" and "Open TAL VMR" have been added to the "File" menu allowing to quickly load a template VMR file in MNI or Talairach space from the "MNITemplates" folder. These VMRs can be, for example, used to visualize multi-subject GLM or ANCOVA results complementing other underlying VMR visualizations such as using the brain of an individual or the result of averaging brains from all participating subjecgts.

 

Bug Fixes

Fine-Tuning Adjustment When running the FMR-VMR coregistration tool, the default (gradient-based) fine-tuning alignment step did not perform well in the previous version. Since the header-based initial alginment works properly, this issue usually resulted only in small deviations when visualizing functional data in subsequently created VTCs with respect to anatomy. This issue has been fixed. To be on the safe side, it is recommended to re-analyze data that has been processed with the default FMR-VMR fine-tuning adjustment tool of the 20.0 version (earlier versions are not affected). We apologise for any inconvenience this may cause.
Non-Mosaic DICOMs When creating FMR or DMR projects from non-mosaic DICOM files, the program would produce empty data sets or crash. This issue has been fixed.
Mesh Scaling When applying spatial transformations to meshes (e.g. to apply ACPC .trf files forward or backward) results were as expected in case that no scalings were involved; in case that scalings were included in the transformation they were not compatible with VMR derived .trf matrices and applied inversely. This issue has been fixed in this version.
Verifying Functional Coverage The "Functional Coverage" dialog is useful to verify how well VTC files overlap in a common normalized space. While one can add individual VTCs for this comparison, it is more convenient to simply add all VTC files that are referenced in a selected multi-run multi-subject design matrix (MDM) file. In previous versions this did only work when called after running a MDM-based GLM analysis. This issue has been fixed.
VTC Creation After mTAL Normalization The template based normalization introduced in BV 20.0 can also be used to perform template based normalization to an approximate Talairach ("_mTAL.vmr") space. In the previous version only a .trf file had been produced but no .tal file that is required in the "Create VTC" dialog and for the FMR normalization workflow of the data analysis manager. This issue has been fixed, i.e. the Talairach template normalization now produces both a "_mACPC.trf" and "_mACPC.tal" file.