BrainVoyager QX 2.6 Release Notes
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This version adds the possibility to use
functionally defined regions as additional
targets during cortex-based alignment (CBA).
Weighting parameters are provided that
balance purely anatomical (curvature-driven)
and functional alignment forces. In case that
homologue ROIs are available for all included
subjects, fCBA allows to perfrom a single
analysis integrating whole-cortex and
ROI-based analysis instead of two separate
analyses. See the topic "Functionally Informed
CBA" in the "Cortex-Based Alignment" chapter
of the User's Guide for further information.
It is now possible to analyze aterial spin
labelling (ASL) MRI data. The new slice-based
and volume-based ASL plugins generate
perfusion-weighted time-course data and
absolute (quantitative) cerebral blood flow
(CBF) maps for single- and multi-subject
analyses. Absolute CBF quantification is
especially useful for (patient) group studies.
For details, consult the documentation
provided by the plugins (select help link in
short description available under "Plugins Description Of Plugins" menu).
Until this release, the EMEG tools used a
spherical head model for distributed source
modeling. This version supports a realistic
head model potentially increasing the
precision of topographic results in source
space. Besides relying on standard
segmentation tools, the new EEG-MEG
forward model routines call the "OpenMEG"
library (http://openmeeg.gforge.inria.fr) to fit
the head model. For detailed instructions on
how to obtain realistic individual head models,
consult the users' guide (EEG-MEG chapter).
While BrainVoyager uses CPU-based
parallelization exploiting multiple processor
cores to speed up performance since many
years, modern graphics cards contain general
purpose processing units (GPUs) that provide
very powerful possibilities to parallelize
calculations. This release is the first that offers
the option to run non-graphical
compute-intense algorithms directly on the
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graphics board. More specifically, sinc
interpolation and sigma filtering can now be
performed on the GPU. Sinc interpolation is
especially important since it can be used in
many compute-intensive routines, including
motion correction and VMR/VMP/VTC spatial
transformations. Depending on the graphics
hardware, the new GPU implementation
achieves results that lead from modest to
dramatic reductions in calculation time.
GPU-based sinc interpolation and sigma
filtering can be enabled and tested using the
"Speed" tab of the "Preferences" dialog. For
more details, consult the "Exploiting the Power
of GP-GPUs" topic of the "Additional
Documentation" chapter in the User's Guide.
Sulcal depth volume and surface maps can
now be created that provide information about
the depth of voxels or vertices within sulci.
Besides scientifically interesting
macro-anatomical information (e.g. how sulcal
depth differs in patient or age groups), the
sulcal depth surface maps may also be used
for surface visualization of folded, inflated and
flattened cortex meshes as an alternative to
the standard curvature-based visualizations.
For further details, check the "Creating Sulcal
Depth Maps" topic in the "Miscellaneous
Tools" chapter of the User's Guide.

Enhancements
MVPA In previous versions the searchlight MVPA
Searchlig tool only provided descriptive information.
ht
With this release, BrainVoyager provides
SVM-based and MANOVA-based
searchlights: At each voxel a SVM classifier or
a multivariate t test (Hotellings T) is now
computed providing accurracy maps (from
SVM version) and F statistics (from MANOVA
version). For details, consult the "Multi-Voxel
Pattern Analysis" chapter of the User's Guide.
MVPA It is now possible to run analyses in batch
ROI-SVM mode to reduce GUI interactions. The new
batch mode tools allow, e.g. to perform and
integrate results of all possible leave-N-out
training testing combinations. For details
consult the "Multi-Voxel Pattern Analysis"
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chapter of the User's Guide.
Regular- The visualization of high-resolution grid
Grid
sampling results have been substantially
Cortical improved now showing rectangular grids
Depth
(instead of lines in only one dimension) as
Sampling well as sampled functional data directly in 3D
space. Furthermore display of grids (and
meshes) can be constrained to be visible only
close to the currently used cut plane; this is a
useful option to precisely follow different depth
level grids or meshes as they run along the
cortex. For further details, consult the updated
topic "Regular-Grid Cortical Depth Sampling"
in the "Tools for High-Resolution Data"
chapter of the User's Guide.
VMP ->
The creation of surface maps (SMPs) from
SMP,
volume maps (VMPs) and mesh time courses
VTC ->
(MTCs) from volume time courses (VTCs) has
MTC
been improved allowing for better control how
access of volume data should be performed
from the vertices of a mesh. When clicking the
"Create SMP" button in the "Surface Maps"
dialog, a new "Depth Integration" dialog will
appear that allows to specify whether volume
data should be sampled at the 3D position of
a vertex only (preferred choice for
mesh-based cortical depth sampling) or
whether functional data should be integrated
along the depth of the cortex. The same
options are also integrated in the "Create MTC
from VTC" tab of the "Mesh Time Courses"
dialog. Furthermore, it can be specified
whether volume data sampling should use
trilinear interpolation (default) or nearest
neighbor interpolation. For details, consult the
User's Guide.
High-Res Cortex-based alignment (CBA) is now
olution
possible also with high-resolution sherical
CBA
meshes. The new "Resolution" field in the first
page of the CBA dialog allows to set one of
three resolutions, high, standard and low.
Based on the chosen setting, the creation of
sphere meshes as well as parameters for
morphing and alignment are adjusted in
subsequent processing steps. lInstead of
standard SPH meshes with 81920 triangles
(40962 vertices), the high-resolution meshes
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use 327680 triangles (163842 vertices).
Since CBA calculations are substantially
slower with these high-resolution meshes, this
option should only be used in cases that
target alignment of functional data with
(sub)-millimeter resolution. For details, consult
the "Cortex-based alignment" chapter of the
User's Guide.
GLM and The default time series normalization method
ANOVA has been changed to percent signal change
since this is most widely recommended in the
literature for (multi-subject) GLM data analysis
(see User's Guide for more details of provided
normalization schemes). In previous versions,
the beta values from the baseline condition
was included as a level of a within-subjects
factor when starting ANCOVA analysis from a
GLM data file. Since the baseline predictor
(and its beta and variance estimation) is not
comparable to other main predictors, it does
no longer appear as a within-factor level (this
has been already changed for ROI GLMs in
the previous release); without the baseline,
the prerequisites for the 2-level mixed effects
summary statistics model for balanced
designs are met (for details, consult the User's
Guide). To help users better judge what model
is defined when changing the number of
factors and covariates, the specified design is
now also described directly in the "Design" tab
(and as before in the "Table" tab). For designs
with one main condition or one contrast, the
single-group t test design is automatically
chosen. It is now also possible to run a
1-between factor model (classical single-factor
ANOVA) in case that only one main condition
is available; in previous versions this could
only be done by extracting betas for one level
first in a VMP file that was then used as input.
For ROI-based ANOVAs, the plotting function
of betas has been improved now separating
data from different groups with different line
colors.
Plugin
While plugins can be programmed with
API cross-platform complex GUI components (GUI
Plots and plugins), it was not possible to provide
Documen graphical output to plot calculated values. This
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version adds the possibility to draw bar
graphs, line plots and scatter plots with a few
simple commands. The produced plots look
identical on Windows, Mac and Linux. For
further information, run the "Plot Demo" plugin
and inspect its source code; for a description
of the new API functions, consult the new
Developer Guide that is available under "Help
-> Developer Guide".
Plugin developers can access pointers to all
major data formats except FMR and MAP
data. New functions to access that data are
now available. The commands for processing
mesh (SRF) data have been extended by
adding functions for loading and saving
meshes and the possibility to remove meshes
from scenes in a surface (OpenGL) window.
For further information, consult the new
Developer's Guide that is available under
"Help -> Developer's Guide".
For some applications it is useful to calculate
the centroid of a patch-of-interest (POI), e.g.
to obtain representative mean (Talairach)
coordinates of a surface area. This is
especially relevant for anatomically defined
regions since for functionally defined POIs the
vertex with highest activity ("peak vertex") is
usuallly used to represent the location of an
area. It is also sometimes relevant to extract
the border of a POI, e.g. in case that one
wants to mark a region without interfering with
the content within that region. The creation of
centroid and border POIs is now possible by
using the "Outline POIs" and "Centroid POIs"
buttons in the new "Convert area POIs" field in
the "Paths / CBA" tab of the "POI Analysis
Options" dialog.
It is often useful to visualize the result of
alignment for specific POIs. While it was
possible to map the location of a POI of one
cortex mesh on another individual's cortex
mesh it was not easily possible to visualize
the location on individual cortex meshes that
were defined on the group mesh. Using the
new "" button in the "" field of the "" tab of the
"" dialog, group-level POIs can now be
projected back onto any individual cortex
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mesh that participated in CBA. For details,
see the "Cortex-based alignment" chapter of
the User's Guide.
Fibers
Fibers are now stored in binary format to
increase reading and writing speed under the
same ".fbr" extension. Old .fbr text files can
still be loaded but should be saved once to
convert them to the binary format. Fiber
visualization has been improved to allow
dynamic displays, e.g. animation of fibers in
group bundles "growing" from start
coordinates to end coordinates; the dynamic
fiber displays also support slice-restricted fiber
visualizations that are used e.g. in the context
of high-resolution grid visualizations (see
above).
Zooming When using the "Zoom-In" and "Zoom-Out"
and
icons in the toolbar on the left side, nothing
Tabbed happened when tabbed view mode was used;
Mode
to zoom document views in or out, one
needed first to switch from tabbed view mode
to multi-window view mode. This is not longer
necessary, i.e. when clicking on a zoom icon,
the program automatically switches to
multi-window view mode and positions the
current sub-window in the left upper corner of
the workspace; the latter increases the
experience of the zooming effect. Note that
this behavior is not implemented for OpenGL
windows since they allow flexible content
viewing also in tabbed view mode.
Touch-Ba The viewpoint in surface windows can now
sed
also be controlled by using touch-based
Navigatio gestures on Mac and Windows PCs. Panning
n
and pinch gestures allow to rotate and zoom
using integrated or external (magic) track
pads on Mac and touch-enabled screens on
PCs running Windows 7.

Bug Fixes
Mixed
ANOVA

When specifying contrasts in a mixed ANOVA
design with one between and one within
factor, different error variances need to be
used depending on the defined contrast. In
previous versions, a more conservative error
variance was always used if a contrast
included cells across groups; if, however the
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same balanced contrast is defined within
groups, a more sensitive error variance can
be used (the same as for the within-factor F
test). This has been adjusted in the current
version leading to more sensitive t maps in
this case.
When projecting POIs into VMRs with
sub-millimeter resolution, the location of the
created VOIs was not correct. This issue has
been fixed.
When applying CBA to transform POIs with
only one vertex into aligned group space the
resulting POI could be empty. This issue has
been fixed.
In case that a VTC file did not had a protocol
attached, the plugin would not work producing
an empty GCM VMP file. This issue has been
fixed.
When using the cross-validation option to find
the C value with best generalization
performance, the value chosen was
sometimes not the one with best performance.
This issue has been fixed.
VOIs were always marked as modified
triggering a "Save VOIs" dialog when quitting
the program. Furthermore, VTC files could
sometimes not be removed from the VTC list.
These issues have been fixed; the displayed
VOI file name should now also correctly
indicate (appended star symbol) whether VOIs
have been modified or not. Furthermore the
display of VOIs is now consistent with the
available VOIs in the VOI dialog when
switching between multiple open VMRs; in
previous versions, VOIs might be shown from
an old VOI file after loading a new VOI file.
When VOI files were loaded containing voxel
coordinates outside the VMR volume, the
program could crash. This issue has been
fixed.
When transformation files were not found for
native, ACPC or TAL transformations, the
respective "To [space]" auto-fill options were
disabled in previous versions. While this is
useful behavior for many cases, it may be that
the respective files are located in another
directory, e.g. when using files from another
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run. In order to avoid restrictions, the "To
[space]" options are now always enabled but
they indicate with the string "auto" whether a
certain space is "reachable" with the
"Auto-Fill" option with files in the local
directory or not.
When converting ROIs defined in FMR slice
space to VOIs, the transformation always
assumed that the target volume has 256
dimensions leading to wrong VOI definitions in
case of native/ACPC space transformation.
When not going to Talairach space (where
this assumption is still made), the program
now asks the user to select the desired
native/ACPC space VMR file in order to
extract the proper dimension values.
When running correlation analysis between
subject's contrast values and provided
covariate values for ROIs in the ANCOVA
dialog, the program could crash. This issue
has been fixed.
Sometimes keyboard shortcuts did not work
properly, i.e. despite pressing the right key(s),
the corresponding keyboard function was not
invoked (e.g. opening a POI dialog). This
issue has been fixed.
The labels for convex and concave curvature
were flipped in the "Graded curvature colors"
field of the "Background And Curvature
Colors" dialog. This issue has been fixed.
When GUI plugins were invoked on the Mac
by launching a GUI plugin, the window would
disappear from view when clicking outside the
dialog. This issue has been fixed.
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