BrainVoyager Support

documentation overview

  • Increase font size
  • Default font size
  • Decrease font size

BrainVoyager QX 2.3 Release Notes

New Features

EEG-fMRI Artifact Correction

In EEG data acquired simultaneously with fMRI, the raw EEG data are contaminated by characteristic artifacts of both technical and physiological origins, such as the gradient (GRA) artifacts, related to the switching of magnetic field gradients, and the ballistocardiographic (BCG) artifacts, related to cardiac activities. These artifacts can now be detected and removed in high-sampling-rate (>=1kHZ) EEG data sets using the "EMEG FMRI Artifact Plugin". The new plugin produces a new protocol file that contains intervals centered in all detected artifacts. Besides detecting GRA and BCG artifacts, this plugin also removes GRA (but not BCG) artifacts using the classical average-artifact-subtraction (AAS) method. In order to also remove the BCG artifact, the "EMEG Artifact Removal Plugin" can be used subsequently; this plugin implements the optimal-basis-set (OBS) method to remove (in principle) any kind of artifact. For further details consult the "Simultaneous EEG-fMRI: FMRI Artifact Detection and Removal" topic in the EMEG chapter of the User's Guide.

POI Path Tools

A new set of tools is available to process and visualize "line POIs"; these POIs are defined as one dimensional lines such as demarcations between brain regions or lines labeling macroanatomical landmarks such as fundi of sulci. The POI path tools allow converting line POIs as fibers (as used in the DTI tools) for advanced visualization options; this conversion process includes a reordering of the vertices within a line POI forming a consecutive path from a starting vertex (usually the POIs reference vertex) to an end vertex. The tools also include the calculation of distances between paths (using a modified Hausdorf metric) that can be used to evaluate the results of cortex-based alignment on POIs used as landmarks across subjects.
The POI path tools are available in the in new "Paths / CBA" tab of the"POI Analysis Options" dialog. For further details consult the "POI Path Tools" topic in the "Tools" chapter of the User's Guide.

AppleScript Support This version adds support for AppleScript on the Mac 64-bit platform. This means that in addition to the standard in-process JavaScript based scripting interface, BrainVoyager QX can also be automated using AppleScript on the Mac. The main difference to the standard cross-platform scripting interface is that AppleScript works from outside of BrainVoyager QX and allows to write scripts that reach beyond a single application. This "out-of-process" scripting serves a similar role on the Mac as the COM interface on Windows with respect to scripting. The scripting interface that BrainVoyager QX exposes to AppleScript is very similar to the standard scripting interface but it has been designed with the particularities of AppleScript in mind. AppleScript is a scripting language targeted also to non-programmers using code with a very readable English-like appearance. For further details, consult the "BVQXAppleScriptingGuide.pdf" PDF file in the "GettingStartedGuides" folder or click on "AppleScript Guide" item in the "Help" menu.

Enhancements

Subject-Specific POI Analysis v2.3.1. While homologue regions align better across subjects in cortex-aligned space than in Talairach space, functionally localized areas still exhibit some variability. In previous versions, a true subject-specific ROI GLM / ANCOVA analysis was only possible in volume space. This version adds subject-specific POI analyses in the "POI Analysis Options" dialog. The new "Access Options" tab allows to specify the "Use subject's POI for time course access" option if POIs have been properly defined for each subject. If, in addition, a multi-subject MDM file is provided, the POI GLM and POI ANCOVA functions will use the subject-specific POI definitions to extract time course data leading usually to improved statistical results when compared to a commonly defined POI.
MTC Preprocessing v2.3.1. While most preprocessing is usually done before creation of MTC files (mainly in FMR space), preprocessing options might be useful also for mesh time course data, especially the possibility to spatially smooth the data along the cortical sheet. This version introduces the "MTC Preprocessing" dialog that allows to perform spatial smoothing as well as standard temporal preprocessing. The dialog is available under the "Analysis" menu.
Handling MTC Files v2.3.1. It is now possible to quickly link MTC files from the local file menu of a mesh (SRF) document using the "Link MTC" item. Furthermore, MTC files are now listed in the "Files" pane in the new category "Recently opened MTC's"; this allows to quickly link an MTC file to the currently active mesh in a surface window; it is thus possible to conveniently establish SRF-MTC links in the same way as when creating VMR-VTC links. When launching the program, SRF-MTC links from the previous session are now also re-established (limited to the "current" mesh in cases when multiple meshes are available in a surface window).
MVPA Trial Estimation: Post-Trial Option v2.3.1. When estimating single-trial responses in the context of multi-voxel pattern analyses, the specified data window for single-trial GLMs is specified with a "pre-onset" and a "post-onset" parameter in the "Trial Estimation" tab of the "Multi-Voxel Pattern Analysis" dialog. In many cases, it might be easier to specify the end of the data window relative to the end of a trial's interval duration. This is useful when using trials that last for several seconds (e.g. short blocks) and it is the appropriate way to handle situations where trials of the same conditon have different durations. When checking the new "Use trial duration" option, the "Post-onset" field will change into a "Post-trial" field allowing to specify the duration of time points relative to the end of each trial.
Scripting: Applying HRF v2.3.1. When building design matrices via scripting, the "ApplyHemodynamicResponseFunctionToPredictor" script function used the Boynton function in previous versions. This script function now uses the standard 2-gamma function instead of the simpler Boynton function matching the default behavior of the GUI-based creation of HRF convolved predictors.
CTA Depth Maps v2.3.1. When calculating cortical thickness maps, there is also a "depth map" calculated indicating the distance of a grey matter voxel from the white-grey matter border. This calculation has been improved. This leads to more precise creation of middle layer volumes (e.g. for cortex reconstruction) when using the "Create Volume" and "Create VOI" buttons in the "Mid-GM Volume" tab of the "Cortical Thickness Measurement" dialog.
SMP Dialog v2.3.1. The "Surface Maps" dialog now allows to delete individual entries by using the DELETE or BACKSPACE key. Furthermore, the CTRL-A (CMD-A on Mac) key combination plus-selects all surface maps (switching from single- to multi-selection mode) and the CTRL-C (CMD-C on Mac) key combination deselects all surface maps.
Brain Extraction This version contains an improved brain extraction tool that increases robustness as compared to the previous tool. As part of the automatic intensity inhomogeneity routine, the improved brain extraction tool handles now also "more difficult" data sets by incorporating basic intensity inhomogeneity correction (high-pass filtering) and improved calculation of bounds for region growing operations.
PD-Based Bias Field Correction While the automatic intensity inhomogeneity correction (IIHC) tools work well for most data sets, scans at (ultra) high magnetic fields may exhibit huge intensity inhomogeneities that are difficult to correct with the existing tools. It has been shown (van der Mortele et al.,) that in such cases the recording of a proton-density (PD) weighted scan greatly helps in reducing large inhomogeneities when dividing the T1 weighted data set by the PD data set. When a PD data set is available, this step can now be performed using the "Volumes > Proton-Density Based IIHC Step" menu usually as a first step prior to automatic IIHC.
EMEG Channel Editor The EEG/MEG tools now allow to visualize the time courses of all channels; the implemented fast "channel scroller" contains basic editing tools allowing to remove channels and intervals that, e.g. exhibit artifacts. If changes are made, the results are stored in updated CTC and PRT files. The channel scroller can be invoked using the "Plot & Edit" button in the "Channel Data Preprocessing" tab of the "EMEG Suite" dialog.
Plugins Updates: RFX-GCM, ICA, GIFTI The "Random Effects Granger Causality Mapping" plugin now supports subject-specific VOI definitions for a homologue region-of-interest yielding usually better RFX results than when using the same VOI for all subjects. The plugin now also supports the (usual) case that subject data is located in different folders (in previous versions, all data needed to be copied to the same folder). Furthermore, the plugin now calculates "dGCM" instead of "dGCM_IT" maps (i.e. no thresholding with the INST maps in order to not filter (limit) the maps). The "Temporal ICA" GUI plugin now operates faster and adds max-lag auto-correlation ranking of the ICA components. The GIFTI converter plugin (version 1.4) is now also a GUI plugin and handles SMP, MTC and POI files besides SRF files.
POI Tools

The tools to inspect and edit patches-of-interest (POI) have been improved, including removal of a limit that allowed a maximum of 255 POIs; furthermore, the "Edit Patch-Of-Interest" dialog (invoked with "Edit" button in "Patch-Of-Interest Analysis" dialog) has been enhanced showing now the number of vertices for a selected POI, a list of all vertices included in the POI definition and an option to remove vertices. There is now also a new table available that shows the number of vertices for all loaded/defined POIs that can be invoked in the new "Paths / CBA" tab of the "POI Analysis Options" dialog. POI labels are now also drawn in higher resolution improving readability of displayed text.

Combining SSMs It is now possible to integrate a sequence of SSM transformations into a single SSM file; this makes it easier to go back and forth between corresponding points in two brains in cases that one SSM step is not enough; this may, for example, happen in case that versions of cortex meshes are used that have different resolution than the one used during CBA requiring 2 or more SSM steps to reach corresponding points. The new tool is available in the "Map A to C" tab of the "Map Mesh to Mesh" dialog that can be invoked by clicking the "Map Meshes" button in the "Options" tab of the "Cortex-Based Alignment" dialog.
Scripting API Updates When creating VMR projects, the internally created V16 data set is now stored to disk. When saving the VMR data with a new name ("save as" command used usually after VMR creation), both files will be renamed as long as they have the default "untitled.vmr/.v16" file name. The new command "CorrectSliceTimingWithSliceOrder" allows to run slice scan correction with a custom slice order (see "Preprocessing.js" script). The "getCurrentDirectory()" function is now a property, i.e. you can use "BrainVoyagerQX.CurrentDirectory" to read and set its value. There are also new properties pointing to common locations: The "PathToData" property points as default to the "BVQXData" folder in the user's "(My )Documents" folder and the "PathToSampleData" points as default to the "BVQXSampleData" folder.
V16 Data Sets The V16 data sets (2-byte versions of 1-byte VMR data sets) are now better integrated in standard processing steps; they are now automatically loaded when specifying "ToSAG" or "IsoVoxel" transformations so that they stay in synch during basic anatomical preprocessing and they now also support the "framing cube" specification. A new option has been added in the "V16 Contrast / Brightness" dialog allowing to keep background voxels black when intensity values are inverted.
Default Location of Data Files Since version 2.2, BrainVoyager sets the default folder to the path associated with the currently active data set in the multi-document workspace. If, however, no document is currently loaded, the default path pointed to the location of the program (or a rather random location). BrainVoyager now looks as default in the "(My )Documents/BVQXData" folder if the "Open Files" dialog is used and if no document is available in the workspace; it is thus recommended to put user data in this location. In case that this folder is not available, the program looks in the "(My )Documents/BVQXSampleData" folder and if this is also not available, it looks in the "(My )Documents" folder.
Surface Window Background Color It is now possible to set an arbitrary color for the background of surface reandering windows, e.g. to white instead of black. This function is available in the "Scene" menu by clicking the "Background Color" item. The specified background color is also stored in the program settings and, thus, preset across program launches.
Vertex TAL Coordinates

When clicking on a vertex of a mesh in the surface rendering window, the program now tries to show not only the system coordinates but also the Talairach coordinates of the vertex in the status bar. Talairach coordinates are displayed only if the VMR that "owns" the surface rendering window is in Talairach space. For inflated and flattened meshes, a folded reference mesh needs to be linked to enable display of Talairach coordinates.
v2.3.1. Talariach coordinates are now also shown in the "POI Details" dialog (available in the "POI Functions" tab of the "POI Analysis Options" dialog).

Import of TBV ROIs Regions-of-interests (ROIs) can now be imported and visualized in FMR projects when post-analyzing data from TBV in BrainVoyager. Although TBV's multi-slice ROIs are not available in BVQX, the import function (via "Analysis -> Region-Of-Interest Analysis -> Load") displays them appropriately and uses data from exactly the same voxels from multiple slices to extract and display the mean ROI time course.

Bug Fixes

Averaging VTCs v2.3.1. It was not possible in version 2.3.0 to average VTC files; when starting this function in the "Combine 3D Data Sets" dialog, the program stopped with an error message of non-matching reference spaces. This issue has been fixed. The dialog is available from the "Volumes" menu ("Combine 3D Data Sets" item) as well as via the "Combine Data Sets" button in the "Talairach" tab of the "3D Volume Tools dialog.
POI GLM With MDMs v2.3.1. The POI GLM functionality did not work in previous versions when using a multi-study design matrix (MDM) file. This issue has been fixed (see also "subject-specific POI analysis" above).
Entering Protocol Dialog v2.3.1. When opening the "Stimulation Protocol" dialog from the surface module, the program sometimes crashed on Windows. This problem has been fixed.
Non-Square AMRs v2.3.1. In case that original slices are non-square, the program embeds them in square matrices during creation of functional FMR projects. This has been, however, not been done for related AMR projects in case they were created from a different recording (e.g. coplanar inplane scans) as opposed to using the first volume of the same functional scan. This issue has been fixed.
POI-GLM with SDM It was not possible to use single-run design matrix (".sdm") files for specifying single-run POI-GLM analyses (only ".rtc" files could be specified) whin the "POI Analysis Options" dialog. This issue has been fixed.
VTC Averaging It was often not possible to average VTC files since BVQX displayed a message indicating non-matching 3D reference spaces between the temporarily created VMR data and the VTC data. This problem has been fixed by properly initializing the reference space of the VMR data to the one of the first VTC data set.
Saving VDW with Attached Gradient Info

When a VDW file was saved that received gradient information by loading a .GRB file, the program crashed. As a workaround, the .GRB data could be attached to the DMR data set prior to VDW creation. This issue has been fixed.

FMR/DWI Data with 256 Matrix Size

Functional or difffusion-weighted Siemens DICOM data with an image matrix size of 256 was wrongly interpreted as of "mosaic" type leading to a crash when importing the data with the "Create Project Wizard". This issue has been fixed. Note that these large EPI matrices are often created simply due to upscaling (interpolation) on the scanner but this does not improve data quality; in order to save disk space and processing time, it is advised to turn interpolation off.

Plugin Command qxSaveDMRAndDWI

The "qxSaveDMRandDWI()" plugin command did not save the DWI data from memory in a file with the specified DWI prefix but did overwrite original DWI data. This issue has been fixed.

IIHC Mask Deselection

If in the "16 Bit 3D Tools" dialog (usually in the context of intensity inhomogeneity correction) an applied mask was deselected, this had no effect. This issue has been fixed: When deselecting the "Apply mask" option, the program now correctly will undo masking by reloading the original VMR file.

ACPC Transformation When transforming a VMR into ACPC space, the "reference space" variable of the resulting VMR was not set to "ACPC" but to "unknown"; this subsequently produced a "non-matching reference space" warning when linking a ACPC-space VTC file; this error could be fixed by manually setting the "reference space" in the "VMR Properties" dialog. In this version, the "reference space" variable is set properly to ACPC space.
Applying Fiber TRF When specifying and applying a spatial transformation in the "Spatial Transformation of Fibers" dialog, dismissing the dialog with a click on the "Ok" button performed another application of the specified transformation. This minor issue has been fixed.
POI Vertex MTC Table When saving a table with time courses for all vertices of a POI ("POI Analysis Options" dialog > "MTC Data" tab > "Tables" button) in a text file, the program would crash. This issue has been fixed.
Script Command Logging When running the "CreateProjectFMRSlicesTimeLooping()" scripting command, the Log pane wrongly reported that a "CreateProjectFMR()" routine is executed. This minor issue has been fixed.