BrainVoyager Support

documentation overview

  • Increase font size
  • Default font size
  • Decrease font size

BrainVoyager QX 2.2 Release Notes

New Features

Auto-Inhomogeneity Correction This version adds the possibility to remove intensity inhomogeneities without the need to manually pre-segment white matter. The new automatic inhomogeneity correction (IIHC) tool can be launched from the "V16ToolsDlg" that can be invoked by clicking the "Volumes > Inhomogeneity Correction, V16 Tools" menu item. The automatic procedure runs several sub-processes including background cleaning, brain segmentation and masking, automatic detection of white matter voxels and fitting of the spatial intensity distribution through labelled white matter voxels. The tool corrects small intensity inhomogeneities from volume coils as well as more complex inhomogeneities resulting from surface coils at high fields. The fitted intensity distributions (bias field) is visualized as a secondary VMR and the improvement in grey / white matter separation can be inspected in displayed pre-/ post- intensity histograms. For details, see this blog entry and the section "Intensity Inhomogeneity Correction" in the User's Guide.
Quality Assurance Tools An important goal of this and future releases is the addition of more quality assurance tools that help to assess the quality and validity of performed analysis steps. The most important verification tool introduced in this release is the "VTC Overlap" tool that allows to visualize those voxels that have been scanned in all subjects participating in a group analysis. For details see section "Verification of Functional Brain Coverage" in the User's Guide. Another quality assurance tool is the automatic creation of motion correction movies (MPEG4 videos in .MOV container on Mac OS X, and .AVI container on Windows); a produced movie shows the slices of the first and last functional volume of a FMR/DMR project as volumes with 3 orthographic cut planes; the movie shows these two volumesin rapid succession which allows to get a good impression of the amount of brain motion; since the same two volumes are also shown after motion correction, the movie also indicates whether motion correction was successuful; furthermore, the last frame of the movie shows a static view of motion (and its correction) with a difference image obtained by subtracting the last volume from the first volume. For more details, see section "Motion Correction" in the User's Guide. Another QA tool allows to check the effect of cortex-based alignment by visualizing the movement of vertices (see below).
Real-Time Volume Rendering While BrainVoyager creates beautiful pictures using surface rendering, some visualizations may be better produced using volume rendering, e.g. in case that one wants to visualize anatomical and functional data with realistic transparency effects. Although BrainVoyager always had a volume rendering tool (in the "3D Volume Tools" dialog), it was working rather slowly and lacked advanced features. With this release a new volume-rendering tool is available that is able to create rendered views in a few 10th of milliseconds by exploiting the possibility of modern graphics hardware (GPU's); modern graphics cards are no longer simple fixed processors but they can be loaded with code that is executed within the graphics card. With the implemented fast GPU-based raycasting tools, rendered volumes can be rotated, translated and zoomed in a similar way as in the surface module using mouse and keyboard. The volume renderer allows to visualize multiple anatomical data sets using transparency and different color ranges. Arbitrary slices through volumes can be visualized using intensity values as color information. Furthermore, any statistical map that is defined for the current volume (VMR) is automatically visualized when calling the volume rendering tool. Supra-threshold fununctional voxels can be visualized on cut slices, by projection to the surface of the brain or by using transparency. Several advanced features including shadows ensure high-quality rendering output. For more details, see section "Real-Time Volume Rendering" in the User's Guide.

Enhancements

MVPA Tools The ROI-SVM tool has been enhanced substantially. SVM learning and testing now supports multiple classes including creation and visualization of "class-vs-other-classes" weight maps. To support this, the VOM data structure and file format has been extended to handle multiple values per voxel and to create multiple native-resolution VMPs. Furthermore, a permutation test is available in the ROI-SVM "Options" dialog allowing to assess whether an observed above-chance accuracy is significant or not. The permutation procedure trains and tests the classifier with randomly assigned (i.e. wrong) labels resulting in a null-distribution of accuracies. The null distribution is automatically displayed in a box-whisker plot togther with the accuracy obtained when using the correct labels and the accuracy of the test data allowing easy assessment of significance. For further details, see section "Assessing the Significance of SVM Accuracy Values" in the User's Guide.
RFX-GCM GUI Plugin A RFX version of the Cranger Causality Mapping (GCM) plugin (version 2.0) is available that allows to run GCMs for data sets of multiple subjects. Since this plugin is written as a GUI plugin, VOI, VTCs and time window specification can be conveniently done in the associated "RFX GCM" dialog. The functional data (VTCs) belonging to each subject are identified and used to run individual GCMs, one for each subject; the result of these GCMs are integrated in two multi-subject volume maps with proper naming of subject maps so that they can be directly used for random-effects statistical results using the "CombineVMPs" or "ANCOVA" dialog. The standard plugin (version 1.5, introduced in BVQX version 2.1) can still be used to process single-subject data sets. For more details, see the RFX-GCM help page available from the "Description of Plugins" page that can be invoked in the "Plugins" menu.
Preference Maps It is now possible to visualize the content of a map that is thresholded by another map. This possibility is an extension of lag / cross-correlation maps that allow to visualize information from one quantity (lag value) that is thresholded by another quantity (correlation value). Since correlation values are in a fixed range of -1 to +1, the two information sources could be expressed in a single quantity (e.g. 3.4 can be decomposed in a lag value "3" and a correlation value "0.4"). In order to allow this feature for general combinations of two quantities, one map can now refer to another map to be used for thresholding the visualized map. This possibility is useful if one wants to show qualitative variables that are thresholded by a quantitative variable. One example are "preference" or "winner" maps that show to which condition a voxel (vertex) responds best. These preferences can be encoded, e.g., by a map with non-thresholded integral numbers indicating different condition indices as a qualitative variable; a second map containing statistical values about the significance of a voxels' preference can then be used to threshold the preference map. BrainVoyager also allows to create such dual maps automatically from a set of standard statistical maps, each containing statistical values for a different condition; to use this tool can be invoked by clicking the "Winner" button in the "CombineVMPs" and "CombineSMPs" dialogs.
MVPA, GLM - Empirical Hemodynamic Responses For GLM calculations, the 2 gamma impulse function with standard parameters is usually a good model of a generic hemodynamic impulse response function. For some purposes, hemodynamic modeling might benefit from using individ measured responses. This is especially relevant for modeling single trial responses in the context of multi-voxel pattern analysis. The GLM dialog as well as the MVPA dialog now allows to specify a "empirical hemodynamic response" (EHR) file. This file must contain measured responses that will be used to fit a (single trial) GLM.
CBA - Vertex Movements As part of the new quality assurance tools, it is now possible to inspect the movement of vertices resulting from cortex-based alignment (CBA); vertex movement is visualized as color-coded surface maps; this tool is useful to inspect CBA results for individual cortex hemispheres; the tool also allows to quantify mean vertex movement of all hemispheres of included subjects in order to reveal which regions in the brain have moved more or less than other regions. The tool is available in the "Vertex Movement" dialog that can be invoked from the "Options" tab of the "Cortex-Based Alignment" dialog. Furthermore, the "mesh-to-mesh morphing" tool has been improved in this version and is now located in the same dialog as the vertex movement visualization tool and a calculated 3D morphing can now also stored as a MPEG4 movie.
EMEG Suite - Import Wizard The EMEG module has been extended now containing a EEG/MEG data import wizard that allows importing EEG and MEG data sets from most raw data files generated, e.g. from CTF, NeuroMag, Neuroscan, EGI, BESA and Brain Vision devices/software. The raw data is converted in the EEG/MEG file format of BrainVoyager QX together with auxiiary files for distributed source modeling if the necessary additional information is contained in the input files. The new wizard can be invoked by clicking on "Import EEG/MEG data" in the "EEG-MEG" menu. For details, consult the "EEG / MEG Raw Data Import" topic in the "EMEG Suite" chapter of the User's Guide.
EMEG Suite - Filter Dialog The EMEG module now allows filtering EEG and MEG data sets and eventually update channel and configuration and protocol data before entering the EEG/MEG distributed source modeling module. The digital filters in BrainVoyager QX can be used to suppress unwanted low and high frequency noise or to enhance a periodic pattern around the frequency of interest. The filter dialog can be invoked by clicking on "Filter EEG/MEG data" in the "EEG-MEG" menu. For details, consult the "EEG / MEG Data Filtering" topic in the "EMEG Suite" chapter of the User's Guide.
Plugins Update The "nifitconverter" plugin (v1.0.8) is now a GUI plugin presenting a dialog to control import and export of nifti files and it now also includes useful image transformations. A new "Temporal ICA" GUI plugin has been added to aid in artefact detection as an add-on to the EMEG Suite. It is possible to extract the temporal ICA components of EEG and MEG continous time-course data sets and to select components for data reconstruction. In order to visualize ICA components (as well as signal distributions across channels for time points of event-related data), the EMEG Suite now allows to show 2D "topo plots". For details, consult the "EEG / MEG Temporal Independent Component Analysis" topic in the "EMEG Suite" chapter of the User's Guide. For developers, the plugins API has been further improved: The plugins constructor, the "initPlugin()" function and the destructor are now called consistently for both pure computational plugins as well as for GUI plugins; this allows to properly manage memory allocation and release; it can be used also to cancel further execution of a plugin by returning "false" in the "initPlugin()" function in case that checked requirements are not met.
Scripting from Matlab BrainVoyager's in-built scripting environment is useful for writing and running cross-platform scripts. It might be, however, desirable to launch BrainVoyager and to run scripts from outside the program. On Windows, this is made possible by the COM (Component Object Model) binaray interface. On Windows, BrainVoyager is running as a COM server allowing all programs and scripts supporting the COM interface to remotely access BrainVoyager's functionality. Since Matlab supports the COM interface, it can be used to script BrainVoyager (as in pre- 2.0 versions). This might be particularly useful for power users who want to mix custom analysis routines written in Matlab with the processing and visualization capabilities of BranVoyager QX. For details, see the "Scripting BrainVoyager QX from Matlab" guide. Other "COM aware" evironments can also be used to automate BrainVoyager, including external script programs written in Visual Basic or JScript.
Scripting Commands

When running scripts from within BrainVoyager, the set of available commands did not allow to read or write data to custom files. This possibility has been added, for details consult chapter 4 "Reading and writing files" in the "Scripting User's Guide" and the script "UsingCustomFiles.js" that is located in the "BVQXExtensions/Scripts" folder after installation. There are now also new commands allowing to run preprocessing of VTC files; the names of the new commands are identical to the ones used for FMR preprocessing and the correct routines are called based on the calling document type (FMR-STC or VMR-VTC); for details, look at the script "PreprocessVTC.js" and "Preprocessing.js". It is now also possible to create MTC files from VTC files using the "CreateMTCFromVTC" command.

Map to VOI(s) The function to convert a map into VOIs has been improved. After clicking the "Convert Map Clusters to VOI(s)" item in the "Options" menu, a new "Convert Map to VOIs" dialog is shown that allows to decide whether each cluster of the current overlaid map should result in a separate VOI or whether the whole map should be converted into a single (large) VOI; the latter possibility is, for example, useful when one intends to analyze all voxels of a statistical map.
Speed Improvements This version of BrainVoyager QX further speeds up compute-intense routines by integrating optimized basic linear algebra routines from the Intel MKL library exploiting MMX, SME and multiple cores. Due to this library the ICA plugin is now significantly faster and can be used for large data sets consisting of several giga bytes. The optimized MKL routines are also used internally for Fourier-based 3D operations.
Submission of Bug or Suggestion Using the new "Submit Bug / Suggestion" item in the "Help" menu, it is now easy to submit a bug or suggestion directly from the running program. This function calls the default email client, creates an email addressed to our support and fills it with detailed information about the computer platform used (Windows, Mac, Linux), the BrainVoyager version and license info. Your bug description or wish/suggestion can then be added and the finished email can then be submitted. Using the generated information in your emails will help our support team to answer your requests as quickly and effectively as possible.
Mac GUI Improvements

The user interface of the 64-bit Mac (Cocoa) version has been enhanced to increase productivity and usability. Mac sheets are now used for message boxes and open/save widgets instead of detached modal dialogs. An important option for file open dialogs is the possibility to remove unwanted files from display. While this is not Mac-like (usually files matching a current filter are shown as well as those not matching the filter, the latter are, however, greyed-out and not selectable), hiding files that do not pass a specified search filter (as on other operating systems) seems to be preferred by many users and is very helpful in case that folders contain many files, e.g. imaging (raw) data. The described settings are optional and can be turned on or off in the "Global Preferences" dialog in the "Behavior of File Open dialogs and message boxes (Mac OS X)" field of the "GUI" tab. Another enhancement concerns navigation in the surface window when using two-button mice; in previous versions right mouse button clicks intended for translation movements often invoked instead the context menu; now the latter is only triggered if one holds down the right mouse button for about a second without moving the mouse. Another improvement is that the Finder now shows icons for standard BrainVoyager project files (VMR, FMR, DMR, SRF); as with other file types, clicking an icon will launch BrainVoyager (if not running) and the selected file will be opened.

Movie Studio In previous versions, movie studio exported rendered frames as a series of bitmaps that one needed to integrate into movies using external platform-dependent tools. In this version, MPEG4 movies can now be created that are stored as standard .MOV (Mac) or .AVI (Windows) movie files. Movie export can be turned on in the "Render Movie" tab of the "Movie Studio" window.
Setting Doc Path When multiple documents are open in the workspace, and one switches from document to document, the default path is now reset to the "core" document path allowing more efficient handling of multiple documents; in previous version the default folder shown when calling a Open File dialog was often not related to the currently selected project but showed a path that was used when another document was the active.document.

Bug Fixes

POI CBA Alignment v2.2.1. When applying CBA transformations to POIs that were defined on individual folded meshes (subject space), the SSM transformation (via a S2S file) wrongly added vertex "0" to the resulting aligned POIs. While this did not affect visualization, it produced slightly wrong results when subsequently calculating POI probability maps. This issue has been fixed.
Changing CBA Parameters v2.2.1. When changing CBA parameters in the "Cortex-Based Group Alignment Parameters" dialog, subsequent CBA does not start showing a "do-not-find-file" message. This problem has been fixed.
S2S CBA Files v2.2.1. When using S2S CBA files that were not located in a folder at a higher level than the referenced SSM files, the program did not find the transformation files. This issue has been fixed.
VMR Gaussian Smoothing v2.2.1. When using the Gaussian smoothing option in the "Segmentation" tab of the 3D Volume Tools dialog (click on "Gaussian" button), smoothing does not work producing a "black" VMR result. This issue has been fixed.
Export To ANALYZE v2.2.1. When exporting data to Analyze (either functional or anatomical projects), an empty project window was shown after successful export and the program could crash when not closing the empty window.. This issue has been fixed.
MTC Properties Dialog v2.2.1. It was not possible to edit properties of a MTC file linked to a mesh since the "MTC Properties" item in the "File" menu was always disabled. This issue has been fixed.
Parametric Protocols and SRF-MTCs v2.2.1. When applying parametric protocols to MTC data sets in the "Stimulation Protocol" dialog, the program could crash. Parametric protocols in SRF-MTC projects also lead to crashes when opening the "Event-Related Averaging Specification" dialog. This issue has been fixed.
CreateMTCFromVTC v2.2.1. The "CreateMTCFromVTC" command could not be used from COM (e.g. Matlab) scripting but worked in BrainVoyagerQX scripts. This issue has been fixed.
Changing VMR Contrast/Brightness v2.2.1. When changing the contrast or brightness for VMRs that do not have an associated V16 file, the resulting VMRs did not reflect the made adjustment, i.e. the VMR was "white". This issue has been fixed.
Project Creation This version improves import of raw data with non-power-of-2 matrix sizes, e.g. FMRs with dimensions that are not 64 x 64 or 128 x 128 and VMRs with image dimensions that are not 256 x 256. While such data sets could be imported in earlier versions, several display option did not properly handle non-standard dimensions.
ROI Float Access When clicking "Table" in the "Extract VTC data for every voxel in selected VOI" field in the "ROI Options" dialog, the extracted data was wrong when accessing VTC float data. This issue has been fixed. This problem did not occur for all other functions, e.g when accessing mean ROI time courses from VTC float data.
MVPA Preparation of separate learn and test runs did not properly work in previous version, i.e. pattern (MVP) files were only created from the "Training runs" VTC list but not from the "Test runs" VTC list in the "Trial data" field of the "ROI-SVM" tab. This issue has been fixed.
Default Script The default script setting in the "Global Preferences" dialog was still set to an old (.qsa) script file and browsing to a new script type was not possible. This has been updated to work with the new JavaScript files. The specified default script file will be automatically loaded when launching the script editor.
Plugins API Access of multiple MTCs from plugins did not work in version 2.1. This problem has been fixed. When using the "qxSaveFMRAndSTC()" plugin command, the data storage format was not saved in FMR files in previous 2.x versions; also the access to the STC data referenced by the FMR was only accessible after closing and reopening the FMR document. These issues have been fixed.
AR(1) Maps When choosing the option to create an AR(1) map before and after correction in the "Serial Correlation Options" dialog (invoked from "Single Study GLM Options" dialog) or in the "Multi-Study GLM Options" dialog, no AR(1) VMPs were created. This problem has been fixed.