BrainVoyager Support

documentation overview

  • Increase font size
  • Default font size
  • Decrease font size

BrainVoyager QX 1.10 Release Notes

Maintenance Update - 1.10.4 (build 1250) - Enhancements and Bug Fixes

Important Info at Start-Up When starting the program, the "Known Issues and Program Updates" web page will be shown within the "Known Issues and Program Updates" dialog. Since this web page is loaded directly from the web, it provides a fast communication channel to users of BrainVoyager QX informing about important known issues as well as available program and help updates. The rules when to show the page can be specified in the "Automatically display page" field, e.g. the web page may be shown at each program start, once per day, once per week, never, or only when the web page has been updated. The latter option is turned on as default. The "Known Issues and Program Updates" dialog can also be called from the "Help" menu.
New ANCOVA Models A new model has been added to the ANCOVA module supporting designs with 2 within-subjects factors and 1 between-subjects (group) factor. The model is specified by chosing the respective number of within and between factors in the "Design" tab of the "ANCOVA" dialog. Furthermore, the ANCOVA model with one grouping factor now supports using more than one covariate.
Segmentation in ACPC Space The advanced and standard segmentation tools were fully supported only in Talairach space since a template file (BrainTalMask.vmr) is used for some segmentation steps (to find ventricles and subcortical structures and to remove the cerebellum). While it was possible to "Un-TAL" segmented brains, these tools now explicitly support ACPC space, which may be an important option for some applications, e.g. cortical thickness analysis. The required BrainTalMask.vmr file is transformed from Talairach into ACPC space using a provided subject-specific ".TAL" file. While a VMR in ACPC space must be loaded before starting the segmentation, a ".TAL" file must be created prior to starting the standard or advanced segmentation routines.
Tow-Gamma HRF for Linear Correlation When linear correlation maps were calculated using the "Linear Correlation" dialog, only the Boynton hemodynamic response function was supported in previous versions. It is now possible to use the Two-Gamma function as the hemodynamic impulse function in the same way as in the context of the GLM. The two-gamma function is chosen as default, but another HRF can be selected in the "Linear Correlation Options" dialog.
Plugin API In previous versions, called plugins had only access to the "current" document. There are now new API functions allowing to access all documents available in BrainVoyager's workspace. This allows to run plugins across multiple documents or to implement functionality requiring the integation of different document types. The "qxGetNumberOfDocsInWorkspace()" function provides the number of documents in the workspace, which can be used to traverse through the available documents. The "qxGetDocumentType(int doc_i)" and "qxGetDocumentTypeName(int doc_i)" functions provide information about the type of a document. The currently "active" document may be retrieved using the "qxGetIDOfCurrentDocument()" function and a new active document can be specified using the "qxSetAsCurrentDocument(int doc_i)" function.
Script-Based VDW Creation While it was possible to create DMR DTI projects in previous versions, it was not possible to transform the diffusion weighted data into 3D space via script functions. The "CreateVDWInVMRSpace", "CreateVDWInACPCSpace" and "CreateVDWInTALSpace" script functions have been added to perform this transformation. The parameters of these functions are the same as those in the corresponding "CreateVTC" functions.
DTI Calculations When calculating diagonlized tensor (DDT) files in DMR or VDW space, an intensity threshold was implicitly used to exclude voxels in the background. This intensity-based thresholding could potentially exclude also voxels in the brain for some DTI data sets. To avoid potential problems, this intensity-based masking method has been turned off as default now. It is, however, possible to turn it on and specify explicitly a threshold value using the new "Intensity-based masking using the b0 volume" option in the "Calculations" tab of the "DWI Data" dialog or in the "Data" tab of the "VDW Analysis" dialog. If the option is turned on, the "Intensity threshold" spin box can be used to specify a threshold value (default: 100).
When creating VDW files, the default settings have been changed in order to better fit the requirments of DTI data processing. More specifically, the intensity threshold for calculating a bounding box has been turned off (to avoid potential exclusion of brain voxels) and "sinc interpolation" has been set as the default interpolation method. You may change these settings in the "Create VDW Options" dialog.
Mean diffusivity and fractional anisotropy maps (DMR/DWI-based MAPs and VMR/VDW-based VMPs) are now represented with specific map types (ID 21 or "MD" and ID 22 or "FA"). Values of FA maps are now in the range 0.0 - 1.0 instead of 0.0 - 10.0.
DTI Fiber Seeding When fibers are calculated after Ctrl-clicking in the surface module or using the "VOI Fiber Tracking" dialog, the created fibers were seeded with a default spatial range and density. The "Fiber Tracking and Rendering" dialog now contains two new entries, "Seed range" and "Density" allowing to specify explicitly how fibers should be seeded. When using large VOIs, it is recommended to lower the density setting to "1" or "2" (default value is "3" resulting in 27 (3 x 3 x 3) fiber seeds per VOI voxel) in order to avoid long waiting times. As opposed to previous versions, changed settings in the "Fiber Tracking and Rendering" dialog are now always used when starting fiber tracking from the "VOI Fiber Tracking" dialog.
Coregistration Slice Lines The possibility to show slice lines had been introduced in a previous version to visualize how FMR slices are located within a VMR volume during FMR-VMR (and DMR-VMR) coregistration. This feature could, however, not be turned off. This is now possible by unchecking the "Show slice lines" option in the "Source Options" tab of the "FMR-VMR Coregistration" dialog.
CBA When running cortex-based alignment (CBA), the alignment sphere could disappear and CBA crash on some oprating system environments. This problem has been fixed. When using multiple cores/processors, CBA reported erroneously "AlignmentError: 0.0". The state of the alignment error is now reported correctly for each cortex hemisphere as CBA progresses.
Loading RTC's in GLM Dialog When loading a RTC file in the "Single Study General Linear Model" dialog, the program could crash. This problem has been fixed.

Maintenance Update - 1.10.3 (build 1202) - Bug Fixes

RFX-GLM While calculated correctly, a wrong value of the beta for the constant predictor has been stored at each voxel when running a RFX-GLM in 1.10.2. This problem has been fixed. The problem did not affect interpretation of RFX-GLM contrasts since all values used for contrasts (betas, explained variance etc.) were calculated and used correctly. While also subsequent within-subjects ANCOVA models were not affected, models using between-subject factors will report wrong results for that factor. If such models were used, it is, thus, necessary to re-calculate the respective between-subjects analyses. Note that this problem did not affect any ROI-based ANCOVA results and it did not affect any design using VMP or CMP data as input.
Saving Data Tables When saving table data from event-related averaging plots and ROI-GLMs to disk, the program would crash. This problem has been fixed.
Adding and Moving VOIs When adding VOIs to the VOI list in the "Volume-Of-Interest Analysis" dialog, the program sometimes confused the identities of the VOIs. This problem has been fixed.
VMR Project Creation After browsing the first file of a VMR project in the "Create Project" dialog, the "Number of slices" field could wrongly report a value of "1000". This problem could be solved simply by overwriting this value with the correct number. This minor problem has been fixed.
VMP LUT Update When changing the overlay look-up table using the "Overlay Look-Up-Table" dialog, VMPs not using an own color table were not updated immediately. This minor problem has been fixed.

Maintenance Update - 1.10.3 (build 1202) - Enhancements

Confound Predictors Confound predictors of a GLM analyses are now displayed as default in the "Overlay GLM Contrasts" dialog. Display of confounds can be turned off in the "Overlay GLM Options" dialog. In order to separate confound predictors from main predictors, names of confounds are now drawn in a yellow color while names of predictors of interest are drawn in a blue color.
High-Pass Filter Default While differences are rather minimal, several tests have shown that the best high-pass filter FMR preprocessing results are obtained using the GLM-based Fourier option. The "High-pass (GLM-Fourier)" option is therefore now set as the default high-pass filter in the "FMR Data Preprocessing" dialog. To switch to another high-pass filter approach, use the "High-Pass Filter Options" dialog.

New Features

Probabilistic Maps It is now possible to create probabilistic functional maps from multi-subject VOIs, POIs as well as VMP and SMP contrast maps. For details, check the "Probabilistic Maps" chapter of the User's Guide and the BV Blog entry Probabilistic Functional Maps. A new map type has been defined for probabilistic maps showing the number of subjects overlapping at a voxel or vertex as a percent value.
Temporal High-Pass Filtering In addition to temporal high-pass filtering in the frequency domain, the "FMR Preprocessing" dialog now offers also to filter in the time domain using a GLM-based approach; the design matrix can be specifyied as a Fourier or Discrete Cosine Transform basis set. The residuals (original data minus fitted data) of the GLM is used as the filtered FMR data. For details, consult the "Preprocessing" chapter of the User's Guide. Temporal high-pass filtering can now also be integrated within statistical data analysis; more specifically, the "Single-Study General Linear Model" dialog now allows to add a Fourier or Discrete Cosine Transfor (DCT) basis set as confound predictors to the design matrix in the "Predictor Functions" tab. The advantages and disadvantages of this approach as compared to a separate preprocessing step are discussed in the User's Guide.
High-Pass Filtering of Design Matrix Temporal high-pass filtering can now also applied to the main predictors of a specified design matrix. Applying the same filter to the design matrix (predictors of interest) as to the data allows to reveal whether a high-pass filter affects signal changes of interest in the data. This feature helps to ensure that the high-pass filter removes only signal changes, which are in a lower frequency band than the signal changes of interes, which is sometimes a source of error in fMRI data analysis.
Cluster Peak Table The "VOI Analysis Options" dialog allows to produce tables showing the center-of-gravity of each VOI as well as additional information. This version extends these capabilities providing the possibility to create a table containing the Talairach coordinates for the peak voxel within a VOI. This option requires overlaying a volume map in order to inspect the map values within each VOI. In a typical application a volume map (e.g. a GLM contrast) is calculated (or loaded) first, then the significant map clusters are converted into VOIs using the "Options > Create Volumes-Of-Interest From Map Clusters" menu followed by a click of the "Table" button in the "Map Peak Voxels" field in the "VOI Analysis Options" dialog. The displayed table can be saved to disk but can also be used interactively: If a cluster (row) is selected, a click on the "Show Voxel" button highlights the voxel with the maximum statistics value by setting the cross to the respective coordinates.
CBA of POIs and SMPs If POIs had been defined on individual (SPH) cortex meshes participating in cortex-based alignment, the defined POIs could not be transformed into aligned space. This is now possible with new functions available in the "Apply cb-alignment to POIs created in subject space" field of the "POI Functions" tab of the "Patch-Of-Interest Analysis Option" dialog. The POI alignment is, for example, necessary when calculating probabilistic POI maps. In order to be able to apply matching CBA (SSM) file for the POIs of different subjects, the new "Subject To CBA Data Assignment" dialog allows to link subject identifiers to SSM files. Established assignments can be saved to disk in the new "S2S" file format for later use. The same tools can also be applied to align surface maps (SMPs) defined in individual space using the "Apply cb-alignment to maps created in subject space" field in the "Surface Map Options" dialog. While SMP alignment is not necessary for GLM-derived surface maps (since CBA GLM's internally apply SSM files to subject's data), it is important for surface maps created with other analysis tools, such as the cortical thickness measurement tool. In order to separate aligned from unaligned versions of POIs and SMPs, the "_ALIGNED" substring is appended to transformed output files.

Enhancements

Single-Run Design Matrix Files The "Single-Study General Linear Model" dialog now saves and loads defined design matrices in a new file format, called "SDM" (ssingle-run design matrix). The previously used RTC format can still be read into the dialog. Among other information, the new format stores the number of confound predictors in the design matrix by indicating the first confound predictor; this information allows to build consistent multi-study design matrices (MDMs) even if individual runs have different numbers of confound predictors. For more details, consult the updated User's Guide.
Improved Multi-Subject Design Matrix Creation In previous versions, multi-subject design matrices could only be built if the number of predictors was identical. With the new support of splitting single-run design matrices in a main predictors and confound predictors part (see above), multi-subject design matrices can now be flexibly build from single-run design matrices by splitting main and confound predictors also in the overall design matrix (MDM file). This provides the flexibility that different subjects/runs may contain different amounts of confounds. The improved creation of design matrices takes this into account and will only require a matching number (and names) for main predictors. This improvement has been implemented for both the standard separate-subject/study GLM as well as for the RFX GLM.
Multiple Confound Predictors A defined design matrix is now explicitly separated in a sub-matrix with predictors of main interest and a sub-matrix with confound predictors. This allows to keep main predictors separated from multiple confound predictors, which may include temporal high-pass filter sets, motion parameters, and artefact rejection predictors. A separating predictor index for the two sub-matrices is automatically defined but can also be manually specified in the "Masking / Options" field of the "Single Study GLM Options" dialog. For more details, consult the User's Guide.
Resolution-Aware Meshes In previous versions, meshes were reconstructed in a space with units of voxel indices. This lead to non-matching meshes when reconstruction was done after advanced segmentation vs standard segmentation tools. The same cause also produced wrong slicing results of meshes from advanced segmentation. These issues have been fixed by reconstructing meshes in millimeter units as opposed to voxel index resolution. Since now the voxel resolution values in VMR files are taken into account, a VMR with 0.5 mm voxels of a subject will be reconstructed in the same space as a VMR with 1.0 mm voxels. This improvement allows to integrate meshes reconstructed from advanced segmentation tools into the standard inflation/flattening pipeline, especially in combination with the mesh simplification tool.
VMP Smoothing Native resolution volume maps (nVMPs) can now be smoothed by using the options in the "Smooth map with Gaussian kernel" field in the "Map Options" tab of the "Volume Maps" dialog. This field includes parameters to specify the full-width-at-half-maximum (FWHM) of the Gaussian smoothing kernel and various options including specification of a repeat value and how lag maps should be treated.
ROI Dialogs The "Volume-Of-Interest Analysis" and "Patch-Of-Interest Analysis" dialogs have been improved allowing now to add additional VOIs / POIs using the "Add" button. Furthermore, the order of VOIs / POIs in the respective list can now be changed using the "Move up" and "Move down" buttons. Editing POI features has also been extended allowing to specify the reference vertex connecting the mesh with the displayed POI name. Besides allowing to edit a POI's "Info" text, the "Edit Patch-Of-Interest" dialog (invoked by clicking the "Edit" button) now helps in editing the shape of a selected POI; to start modifying a POI, the "Draw Mesh Colors" button can be used to project the POI on the mesh by setting the vertices mesh color (i.e. not as an overlay); the marked POI vertices can then be edited using the mesh drawing tools, which automatically will use the correct color index; finally the modified set of vertices can be defined as the new POI definition by clicking the "Set Vertices" button in the re-entered "Edit Patch-Of-Interest" dialog.
POI Area The "POI Details" function has been extended now providing a measure of the area of a POI. To calculate the POI area, it's vertices are projected (internally) on the current mesh; then all triangles "covered" completely by the POI vertices are identified and their area calculated; finally the sum of the areas of all identified triangles is determined as the area of the POI. Note that this implies that POIs with line shapes report an area of zero since such POIs usually do not cover all three vertices of "touched" triangles.
RFX Summary Statistic Approach The ANCOVA module now supports the summary statistics approach of random effects analysis. After specifying a GLM (or reading table data), this approach is enabled by setting the number of all factors and covariates to zero. At this stage, the "Contrast" page appears allowing to specify a contrast, which is applied to the data of each subject (this is the same procedure as used for correlation of subject's effects values with covariate values). The mean of these contrast values is then compared to zero using a t test, which implements the same statistic as is performed in the "old" RFX approach available in the "Overlay GLM Options" dialog. For more details, check the User's Guide, which contains also a comparison of the summary statistics approach with the one within-factor ANOVA model.
Brain Peeling In previous versions, the borders of the segmented brain could show small "holes" (missing voxel values) after running the "brain peeling" tool; this problem has been fixed by using a post-segmentation "get fringe" procedure. As default, a single (one voxel expansion) "get fringe" step is performed now when clicking "Segregate Brain From Head Tissue" in the "Volumes" menu. For more fine-grained control, the "No. of post get-fringe steps" option has been added in the "Brain peeling" field of the "Segmentation Options" dialog. Furthermore, the "Advanced Segmentation Tools" dialog now also provides this option with a default value of "2" steps (as had been implicitly performed in previous versions).
Multi-VOI Event-Related Averaging It is often useful to compare averaged event-related time courses across different regions-of-interest (ROIs). This could be done in previous versions by adding the averaged event-related output from individual ROIs into a common plot window by using the "Load Data" and "Add Data" buttons in the "Plot Options" dialog. As a convenience function, this is now possible for VOIs in one step by using the "Multi-VOI event-related averaging plot" field in the "VOI Functions" tab of the "VOI Analysis Options" dialog. First select the desired VOIs in the "Volume-Of-interest Analysis" dialog, then use the "Browse" button in the "Multi-VOI event-related averaging plot" field to select an event-related averaing (AVG) file, and finally press the "Generate Plot" button to create the multi-VOI event-related averaging plot. Note that the color for the resulting plot line(s) belonging to the same VOI are set as the color specified for that VOI.
Motion Correction Scripting The motion correction commands "CorrectMotionEx" and "CorrectMotionTargetVolumeInOtherRunEx" always used trilinear interpolation in previous versions. The third parameter "InterpolationMethod" allows now to specify the same interpolation methods as used in the GUI; value "1" (or "0") is interpreted as trilinear interpolation, value "2" is interpreted as "trilinear-sinc" (trilinear interpolation for detection of motion parameters, sinc interpolation for final transformation) and value "3" is interpreted as "sinc-sinc" (sinc interpolation is used for detection and transformation).
Individual VMP and SMP LUTs The "Volume Maps" and "Surface Maps" dialogs now allow to specify overlay look-up tables (OLT) for individual sub-maps. While sub-maps could have individual color ranges in previous versions (interpolated between a specified "min" and "max" color), look-up tables allow to define optimized color palettes for special purposes. As an example, new OLT's are provided in the "MapLUTs" folder, which are optimized for highlighting transitions in probabilistic maps.
GUI Improvements Many minor GUI improvements have been performed, including: selecting contrast values ("+", "-") behaved unintuitvely when clicking in quick succession; clicking the "RFX ANCOVA" button in the "Overlay RFX GLM Contrasts" dialog did not open the ANCOVA dialog when launched from a surface-based GLM; default names of overlaid ANCOVA tests have been made more meaningful; the "Interpolation" flag in the "Overlay Maps" dialog was not always synchronized with newly created maps; when creating multiple contrasts (for each subject) using the "Create maps for all defined contrasts" feature in the "Overlay GLM" dialog, the new option "Show maps during creation" allows to turn off display of the successively created maps, which speeds up the batch creation of maps substantially; the "Volume Maps" (native resolution) and "Surface Maps" dialogs now show the doc file (VMR or SRF) and the name of the VMP or SMP in the dialog's title bar.
Cross-VTC Intersubject Correlation While available in earlier versions, the intersubject correlation feature has been improved and extended in this release. This feature allows to correlate the time course from two subjects for homologue Talairach voxels. For further details consult the "Cross-VTC Intersubject Correlation" topic in the "Additional Tools" chapter of the User's Guide.
Deletion of sub-SMPs In previous versions, the current set of maps in the "Surface Maps" dialog could be deleted using the "Delete All" button. As in the "Volume Maps" dialog, it is now possible to delete individual sub-maps by selectin a map followed by a press of the "DELETE" key.
Colors in Voxel-Beta Plot Colors for conditions were sometimes not correctly drawn in the "Voxel Beta Plot". In combination with other enhancements (predictor colors are now saved in the new SDM file), the correct colors should now be displayed in all cases.
File Format Changes The file format to store GLM data has been changed slightly containing information about confound predictors. The User's Guide contains a specification of GLM files in the "File Formats" chapter.
Design Matrix Dialog Visualization of design matrices has been improved. The "Design Matrix" dialog now handles also large design matrices when zooming in and out; it also has now a "stretch" factor allowing to change the width of columns in relation to the height of rows in graphical display mode.
Correlation For convenience, the reference time course defined in the "Linear Correlation" dialog is automatically saved to disk and it will be available for immediate display in a subsequently opened "ROI Signal Time Course" dialog.
TMS Neuronavigation The neuronavigation module did not work properly in the 1.9 versions. This problem has been fixed. Furthermore, some improvements have been added including saving of coil and beam positions allowing to calculate statistics about targeting a desired area.

Bug Fixes

Covariate Correlation in ANCOVA module When using Volumes-Of-Interest (VOIs), the calculation of correlation values between subject's effect (contrast) and covariate values did not work properly in previous versions. This problem has been fixed. Futhermore, the output of the VOI covariate correlation has been extended to now show all included covariate and dependent variable values used for calculation. The mentioned problem did not occur when maps were calculated as long as covariate values were provided as integer values; furthermore, covariate values are now interpreted as real values as originally intended.
Saving RTCs from Linked MTCs When a time course from a linked MTC file was displayed in the "POI Signal Time Course" dialog, saving the time course using the "Save RTC" button produced a crash in previous 1.9 versions. This bug has been fixed.
Saving Residuals The possibility to save GLM residuals did not work correctly in previous versions. While the residuals were computed correctly, negative values resulted in most cases due to z-normalization, which can not be represented in the present unsigned two-byte integers of VTCs and STCs. This has been fixed in this version by turning off z-normalization in the "Single Study GLM Options" dialog as soon as "Save residuals" is selected in the "Serial Correlations Options" dialog, which can be invoked by pressing the "Residuals" button in the "Single Study GLM Options" dialog; furthermore, the "Keep mean" option is forced to be on. In this way, the calculated residuals are stored correctly and can subsequently be used as expected.
Contrast Map Creation For Each Subject When creating multiple contrasts for each subject using the "Create maps for all defined contrasts" feature in the "Overlay GLM" dialog, the created map names were not always suitable for direct VMP import in the ANCOVA module since the name of a subject could appear more than once in the map name, e.g. "Subject 1: Faces > Subject 1: Houses"; this has been fixed, e.g. the name used as an example now becomes "Subject 1: Faces > Houses".
Predictor Colors in GLM Dialog Since 1.9.10 it is possible to display predictors in color in the "Single-Study General Linear Model" dialog using information from an attached protocol. In case that the first condition was not droppped when defining the design matrix, colors could be assigned wrongly. This problem has been fixed.
Mesh Morphing A (small) memoery leak has been fixed. This could potentially lead to a memory error during cortex-based alignment with many (e.g. 50) hemispheres.
Detach VTC/MTC Detaching a VTC by pressing the "Detach VTC" button in the "Link 3D Volume Time Course (VTC)" dialog did not detach the linked VTC data from the current VMR. Likeweise, when detaching a MTC by pressing the "Detach MTC" button in the "Mesh Time Courses" dialog did not detach the linked MTC data from the current mesh. This problem has been fixed for both cases.
ROI Details The "VOI Details" feature (available in the "VOI Functions" tab of the "VOI Analysis Options" dialog) reports information about individual voxels belonging to a VOI including information about map values, if available. This feature did not provide information about beta maps introduced in the last release. Information about beta values has been added now. Furthermore, values from the newly introduced probabilistic maps are also reported.