BrainVoyager Support

documentation overview

  • Increase font size
  • Default font size
  • Decrease font size

BrainVoyager QX 2.0 Release Notes

New Features

Multi-Voxel Pattern Analysis (MVPA) A comprehensive set of tools to analyze distributed patterns of activity is now available and accessible via the Multi-Voxel Pattern Analysis dialog. Using Support Vector Machines (SVMs), classifiers can be trained on data in small or large ROIs to discriminate activity patterns from different conditions. Furthermore, local information as well as sparse global patterns can be mapped in the whole brain using searchlight mapping and recursive feature elimination (RFE). As a preparatory step to use SVM classifiers, the MVPA dialog also offers tools to estimate single-trial responses at each voxel, which may also be of interest for univariate data exploration. For an introduction in SVMs and the available MVPA tools, check episodes 2-5 in the BrainVoyager QX 2.0 series in Rainer's BV Blog. For more details about the MVPA-related tools, consult the "Multi-Voxel Pattern Analysis (MVPA)" chapter in the BrainVoyager QX User's Guide.
EMEG Suite The new EEG / MEG distributed source imaging tools allow to analyze prepared EEG and MEG data in BrainVoyager. Besides plotting time course and time-frequency channel data, the most important feature of the "EMEG Suite" is to map the channel data into cortical source space using all major inverse modeling approaches including weighted minimum-norm, LORETA, LAURA and LCMV beamforming. The obtained cortically constrained distributed source data can be visualized easily on cortex meshes; for any region-of-interest, source time courses can be reconstructed ("virtua electrode"). Furthermore, movies on cortex meshes of dynamic distributed solutions can be easily created using "Movie Studio" (see below). In combination with fMRI data, the EMEG Suite allows fully integrated EEG-fMRI and MEG-fMRI modeling and analysis, e.g. by providing fMRI-constrained distributed inverse modeling and by providing the possibility to add predictors to fMRI design matrices derived from source EEG/MEG data. For details about the EEG/MEG distributed source imaging tools consult the "EMEG Suite" chapter in the BrainVoyager QX User's Guide as well as the "EMEG Suite Getting Started Guide", which has been placed in the BrainVoyager QX folder during installation. Note that the EMEG Suite requires an extended license (EMEG Module); contact Brain Innovation for details about licensing and how to get a trial version to test the EMEG Suite.
Movie Studio Movie Studio allows to create stunning movies for different purposes including visualization of dynamic activation patterns. Movies are created by adding the information contained in a current rendering scene as a "state frame". Between successive state frames, BrainVoyager then calculates additional inter-frames creating smooth transitions. States describe one or more meshes and store information about the viewpoint, mesh slicing levels as well as mesh vertex colors and vertex coordinates. If, for example, the mesh vertex coordinates change from one state (e.g. folded mesh) to the next (e.g. inflated mesh), Movie Studio will calculate a smooth inflation animation between the two states. Furthermore, bitmaps can be added to any state allowing to visualize stimuli on a virtual screen and to present explanatory information. For further details, check the chapter "Movie Studio" in the User's Guide.
64 Bit Versions Previous versions of BrainVoyager only supported 64-bit on Linux. BrainVoyager QX 2.0 now supports 64-bit also for Windows and Mac OS X. While 64 bit versions do not increase computation speed (at least not substantially), they allow exploitation of working memory beyond 3 GB, which is the limit on most 32-bit operating systems. In practice, requesting a continuous piece of only 1 GB might be already rejected by a 32 bit operating system due to fragmentation of the available memory space. A 64 bit operating system solves these issues since it allows a program access to large (continuous) blocks of working memory beyond the practical “1-2 GB” limit. Even if a system has “only” 4 GB of working memory installed, 64 bit programs can successfully request considerably larger pieces of working memory than 32 bit versions, especially on Windows. And if more than 4 GB are installed, only a 64 bit system can use that memory. While BrainVoyager QX uses working memory carefully, several tools will greatly benefit from a large working memory space including advanced cortex segmentation, cortical thickness analysis, Multi-Voxel Pattern Analysis (MVPA) and EEG / MEG source imaging analysis.
Float Data Functional (FMR, VTC) and diffusion-weighted (DMR, DWI) data has been stored as 2-byte integer values in previous versions. While this is sufficient to represent scanner data (usually 12 bit) without loss of precision, the execution of a series of (pre-)processing steps accumulates rounding errors since resulting values have to be rounded to the nearest integer. To avoid this problem, BrainVoyager 2.0 now uses floating point numbers (4-byte float) as default for functional and diffusion-weighted data. The only disadvantage of the float format is that the data occupies twice as much space on disk and computer memory. If you do not want to use the new storage format (for all your projects or for finishing a “integer” project), you may turn off the new storage format for FMR/DMR projects in the “Settings” dialog. The choice made here is stored to disk and used as the default storage format also for subsequent BV sessions until explicitly changed. If you create a project with the “Create Project” dialog, you can temporarily change the storage format for a new project in the “Advanced” section.

Enhancements

Graphical User Interface The Graphical User Interface (GUI) has been substantially enhanced with efficiency in mind. The first new GUI feature one encounters when launching BrainVoyager QX 2.0 is a new option to reload the last session. When turned on, this option will load all documents that were open when the program was closed last time. Note that this function goes beyond a simple reload of a document (VMR, FMR, DMR, SRF); it includes reloading files linked to a document including VTCs, MTCs, GLMs, VMPs, and SMPs as long as they are still available on disk. Another GUI improvement is the separation of the "Files", "Log" and "Info" in separate panes that reside at different regions of the main window. This allows to have them visible simultaneously. In order to quickly show or hide these panes, three new toggle icons (“Files Pane”, “Log Pane” and “Info Pane”) are now available in the main toolbar (see snapshot above). The panes can also be shown or hidden via respective entries in the “View” menu. A new "Full Screen" icon allows to switch to full screen mode allowing to exploit all screen real estate for working with document(s). The Escape key (or Cmd-F / Ctrl-F) leaves fullscreen mode restoring the previous state. Furthermore, the workspace of now supports a “tabbed” multi-document interface (MDI). Combined with the classical sub-window view mode, BrainVoyager QX 2.0 aims to combine the best of both worlds in an elegant interface. For a more detailed and comprehensive description of the new GUI functionality, check Episode 1 of the BrainVoyager QX 2.0 blog series.
Improved FMR/DMR-VMR Alignment While the fine-tuning alignment in previous versions worked often well, there were also cases when alignment failed, especially when (non-removed) inhomogeneities were present in the target intra-session VMR data set. This dependency on intensity inhomegeneities is the consequence of the used goodness of alignment measure, which considers the sum of squared intensity differences (the smaller the better). In BrainVoyager QX 2.0 a more robust alignment routine has been implemented, which does not use intensity per se but gradient information as its goodness of alignment measure. While intensity differences strongly depend on inhomogeneities in the data, gradient information is largely unaffected since it evaluates the change of signal intensity with respect to neighboring voxels. More specifically, the implemented "Normalized Gradient Field" (NGF) algorithm considers a source and target volume as aligned, when intensity changes in the same way in both volumes at corresponding positions. Another improvement of the new alignment routine is the (optional) inclusion of scale and shear parameters extending the previously performed 6 parameter rigid (3 translations + 3 rotations) alignment to 9 parameter (rigid + scale) and full affine (12 parameter) transformations. As default, the program starts with a rigid alignment followed by a 9 parameter alignment. The included fit of 3 scale parameters seem to be especially beneficial for some EPI images with different "stretch" in image space along the frequency and phase encoding gradient. The "FMR-VMR Alignment Options" dialog available in the "Fine-Tuning Alignment" tab of the "VMR-VMR Coregistration" dialog allows to include also the full 12 parameter alignment when desired. When turned on, a new pre-alignment step will search for good starting parameters; this initial explorative search step can be often even used in case that the FMR and VMR files were not scanned in the same session. While available as an option before, the edge overlay display is now used as the default visualization scheme for the two fused data sets.
Parallelized Spatial Transformations BrainVoyager QX 2.0 continues a process aiming to parallelize all compute-intensive routines exploiting the power of multi-core, multi-CPU computer systems. In the 2.0 release, the creation of VTC and VDWs has been parallelized leading to a 2x (dual core laptop) to almost 10x (8 core hyperthreading desktop workstations) speed gain. When using trilinear interpolation, the gain may be less visible than when using sinc interpolation since disk IO performance may become a limiting factor. Due to the obtained speed gain, the usage of sinc interpolation for DWI/VTC creation becomes a more viable option, e.g. when analyzing DTI or high-resolution fMRI data. The spatial transformation of VMR data sets using trilinear or sinc interpolation has also been parallelized with similar speed gains. This will reduce, for example, the creation of VMRs with 0.5^3 resolution from 1mm^3 data sets as is performed usually for advanced segmentation. Due to this speed gain, it is also recommended to run the "Re-Apply" tool with sinc interpolation when a VMR data set has been trasformed into ACPC or Talairach space with several successive interpolation steps.
CBA Improvements Cortex-based alignment (CBA) is a useful tool to align macroanatomical structures (gyri and sulci). Since CBA is based on curvature information, homologue sulci and gyri need not explicitly be labelled in different brains. It is, however, important to start CBA at a stage where sulci and gyri are already close to each other on the sphere. In previous versions, hemispheres of different brains could be so much deviating (despite initial ACPC or Talairach normalization) that in some cases wrong alignments would result where a sulcus (gyrus) in one brain would be matched with a non-homologue sulcus (gyrus) in another brain. In order to reduce the likelihood of partial mis-alignments, BrainVoyager QX 2.0 offers now the possibility to run a rigid spherical pre-alignment step prior to CBA. In this "rigid" alignment step, a source sphere is rotated in a specified range and the alignment error for each parameter set (rotation values for three axes) is recorded. The parameter set producing the best fit (smallest alignment errror) with the selected target sphere will be selected and used to perform a rigid pre-alignment when starting the CBA procedure. While this step is not an absolute guarantee for avoiding mis-alignments, the likelihood to get optimal results is substantially improved after performing this step. Besides rigid pre-alignment, the coarse-to-fine strategy has been improved including better default parameters for cortex-based alignment at different curvature smooth levels providing better and more robust alignment results.
CTA Improvements The aalysis of cortical thickness requires precise segmentation of both the inner (white matter / grey matter) and outer (grey matter / CSF) boundary of grey matter. The advanced segmentation tools use, among other things, local intensity histogram analysis to determine the inner grey matter boundary producing good results. For the detection of the outer boundary, however, only global intensity histogram analysis was used in previous versions. The 2.0 release adds local histogram analysis leading to substantially improved estimates also of the outer boundary. The "Advanced Segmentation dialog" also offers the new possibility to create volumes-of-interest (VOIs) from the estimated boundaries. The created VOI contours can be (transparently) overlaid on the original 3D intensity data allowing a more easy check of the quality of resulting grey matter segmentations. Furthermore, the "Cortical Thickness Measurement" dialog has a new "Mid-GM Volume" tab allowing to create a segmented volume running through the middle of grey matter. The created volume can serve as the basis for better cortex reconstructions since a surface through the middle of grey matter does not bias surface curvature towards gyri or sulci. These and other improvements are described in the updated "Cortical Thickness Analysis" chapter of the User's Guide.
VOIs and VOMs The tools to work with volumes-of-interest (VOIs) have been improved, e.g. by adding support for different resolutions, VMR offsets and left/right conventions making them more flexible but also more secure, e.g. by prohibiting linking VOIs to non-matching VMRs. The new "VOI -> Draw in VMR" function in the "VOI Functions" tab tab of the "VOI Analysis Options" dialog allows to transform VOIs back into marked VMR clusters allowing to apply VMR tools for further VOI processing. VOIs may also be "dilated" using the "Expand selected VOIs" option in the same dialog, which is especially useful in the context of ROI-based fiber tracking. While getting more powerful, VOIs are always defined in VMR voxels, which makes them not ideal for some applications, for example in the context of ROI-based MVPA (see above). The new "VOM" data has been introduced to solve this issue as well as providing additioanal possibilities. A VOM file stores (at present only one) "volumes-of-interest" in "native resolution", i.e. the coordinate space matches the one of native resolution VMPs instead of that of VMRs. While VOIs can, of course, be transformed internally into native resolution space, an explicit storage of voxels in that space has many advantages. In addition to native resolution space, a VOM file may store associated map data for each voxel. As opposed to VOIs "knowing" only that a voxel with a certain coordinate belongs to a VOI, the voxels in a VOM file may each have an associated floating point value. In the context of support vector machines, for example, VOMs are used to attach weight values to voxels in native resolution space. VOMs can be created using the "Create VOM" dialog accessible through the "Options -> Create VOI-Map" menu item; VOMs can be visualized using the "Visualize VOMs" dialog accessible through the "Options -> Visualize VOI-Map" menu item. This dialog offers the possibility to visualize VOM map values as surface plots across selected sagittal, coronal or axial slices. Furthermore, a VOM can be transformed in a volume map with the same native resolution allowing to visualize the contained map values using standard 3D browsing.
Minimized VMRs A helpful feature introduced in the context of advanced segmentation is the possibility to remove the empty space around a VMR and only save the data block containing non-zero data. Similarly as for VTCs and VMPs, a set of offset values are stored in VMR files to keep the knowledge about the "real" position of the sub-volume in a specific embedding space (e.g. 256^3 or 512^3). When using the "Minimize" button in the "VMR Properties Options" dialog (e.g. after brain peeling), not only memory and disk space is saved but also the visualization of the MRI data is improved (e.g. larger view of the brain) due to the removal of the empty space around the brain/head. A problem of this approach in previous versions was that VOI and VTC data were unaware of this approach with the result that VOIs and time course data were not placed correctly in a minimized VMR, e.g. in ACPC or Talairach space. In BrainVoyager QX 2.0, all major file formats linked to a VMR (VOIs, VMPs and VTCs) are now aware of minized VMRs respecting the VMR offset values. Moreover, when new VOIs or maps are created, the new routines make sure that it does not matter whether the data is created on minimized or non-minimized VMRs since coordinates are now interpreted with respect to the framing cube and not the actual dimensions of a VMR.
Plugins Since each platform now supports both a 32 bit and a 64 bit version, plugins are no longer installed in the "BVQXExtensions/Plugins" folder but in either "BVQXExtensions/Plugins_32" or "BVQXExtensions/Plugins_64" depending on the installed BV version. This avoids (accidental) overrides and to have at the same computer both versions (this is possible, e.g. on Mac OS X). The plugin API has been updated to support the new float format for FMR/DMR and VTC/VDW data sets (see above). While the update has been done with minimal changes, some commands had to be modified and some new functions had to be added. The FMR header, for example, has a new entry called "STCDataType"; depending on its value (1 integer data, 2 -> float data), a corresponding command to access the correct pointer to the data must be used (e.g. qxGetSTCIntDataOfCurrentFMR or qxGetSTCFloatDataOfCurrentFMR). For details on this and other changes, consult the remarks in the "Plugin_FMR_Header.h" and "Plugin_VTC_Header.h" header files and the general "BVQXPluginInterface.h" header file as well as the updated description in the User's Guide.
Surface Maps Dialog As opposed to the "Volume Maps" dialog, the "Surface Maps" dialog was still "blocking" (modal) in previous versions. With the 2.0 release, this dialog is now also non-blocking allowing to keep the dialog open when performing related tasks, e.g. to navigate in the surface window. The dialog now also comes with tabs in order to reduce the size of the dialog. These changes may help increase work productivity.
New Plotting Options Several new plotting dialogs have been created, including plotters for matrix data, multi-plot layouts and surface plots. The matrix plotter is used in the context of MVPA (to plot training data) and EMEG (to plot single-trial time course as well as time-frequency data). The multiple sub-plots dialog is used to present averaged channel time course data in the EMEG module. Also the standard plotting dialog, used in many places (e.g. beta plots, GLM fits, histograms), has been improved, especially the associated "Options" dialog, which can be called (as before) by clicking within the dialog. The available options are now better arranged using a tabbed layout. Furthermore, the defined colors for plotting lines are now directly visualized in the list of plot items.

Bug Fixes

FMR Preprocessing v2.0.8: When several FMR preprocessing steps were selected in the "FMR Preprocessing" dialog in the previous version (2.0.7), the final peprocessing result would not always contain the results of all performed preprocessing steps. There was no problem when executing single preprocessing steps or when using scripted preprocessing. This issue has been fixed. To be on the safe side, we recommend repeating FMR preprocessing with this version for FMR files analyzed in earlier versions of 2.0.
Plugins v2.0.8: On some platforms not all plugins provided were visible in the menu. This has been fixed. You can also use the "Help >Plugins Web Page" menu item to inspect and eventually download plugins from the BrainVoyager web site.
Average VMR v2.0.8: The function to average VMRs (typically used to get an average VMR file in Talairach space for a group of subjects) did not work in previous 2.0 versions. This problem has been fixed.
Patch Selection Size v2.0.8: When clicking on a mesh to show an associated time course, the patch size (determining the number of vertices included) can be adjusted in the "Time Course Selection Options" dialog available from the "Meshes > ROI Time Course Selection Options" menu item. This function did, however, not work in previous 2.0 versions. This issue has been fixed.
Rename DICOM v2.0.7: In the first release of 2.0 (version 2.0.6), the "Rename DICOM" tool did not work for all data sets. This problem has been fixed.
MTC Creation When creating a MTC file from a VTC file, the calculation of intensity values for a given voxel was suboptimal due to wrong interpolation of values of voxels in the neighborhood. This problem has been fixed. It is recommended to re-create MTC files with BVQX 2.0 (a fix for the 1.10.4 version is also available) if possible, in order to obtain MTCs with the highest precision. Note that the direct creation of surface maps from volume maps (not via MTCs) was not affected.